Auto-Cancellation did not work

This sequence my be important.

  1. Before retiring last night, put the Mac into Sleep Mode (auto setting).

  2. This morning, checked my auctions because they were due to finish in about 60 mins time. I think 429 of them with an auto0cancel of 60 mins.

  3. As per normal there were two messages on the screen. Basically they said Mac didn’t log off because GS had some auto-cancel items active. I THINK THIS MESSAGE IS THE CAUSE OF WHAT FOLLOWED.

  1. Noticed that the cancellation time was 57 mins and items were still active

  2. Tried to force a reread of the Smart Group by going into Edit. No change.

  3. Thought it might reactivate if I closed and then re-opened GS but I had to perform a "Force Quit’.

  1. Tried an update to the latest version (just one higher than where I was), That hung.

  2. Did a force quit. Restarted - GS performed an Index. The first block of items remained active but the auto cancel started with the items after them.

  3. Stopped that block manually which was successful but they still remained in my Smart Group. Look at 27mins

MY SUGGESTION (for what its worth). Please implement an option for turning off the message Still have active auto-cancel items". I suspect that the issues will go away.

Hi GS Team
Can I get a response to this issue please?

BTW. I think this also slows down the Quitting of GS.

Could it be that you (accidentally) logged-out from your macOS user account instead of putting the Mac to sleep?
This would explain the info message you showed in 3.

It would be helpful to know what you have selected at that time in the GarageSale preferences > eBay > Advanced > Perform Auto Cancellation

However, the next time you run into the same situation again, selecting “Stop Listings due for automatic cancellation” from the Listing menu will trigger the auto-cancellation procedure.

Regards, Kristian

What will this trigger? All overdue listings or all that are in the que to be auto cancelled?

I am guessing this was the issue.

Correct me if I am wrong but does this mean that if you have a single item due to be cancelled in 20 days time it will prevent “Sleep”?

On the subject of Auto Cancellation, The old Auto cancelled and relisted items stay stuck in the Auto cancelled enabled smart folder. It makes me one by one hit delete to move them from the auto cancellation folder.The setting I have set is to move original to: Auto cancelled listings and they are also duplicated in the Auto Canceled Folder.

Screen Shot 2020-05-08 at 10.37.05 AM

Thin I am missing something here.

I deselected at prevent sleep

Have restarted a number of times

But I still get these messages:

@davidelliott If you want to log-out from your Mac the system has to quit all running applications. This has nothing to do with the sleep mode.
Since GarageSale always warns you if there’re pending events or auto-cancellations, the system is not able to quit GarageSale. You have to do this by your own then or better quit GarageSale first before logging-out.

Regards, Kristian

Ok Kristian

A couple of questions for you.

  1. Can I turn off the “pending Auto Cancellations” Message?

  2. When I log off in GS, how does GS determine that there are pending auto cancellations? Does it check all messages or is there a single Boolean Flag that says at least one message has auto-cancellation turned on? I ask because GS now seems quite slow to quit.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.