GarageSale 7 opens without my database

Upgraded to GarageSale 7 and GarageSale 6 database imported and was accessible. Was prompted to install an update the other day, 7.0.5(783). When GarageSale 7 reopened I couldn’t access any listings that were created with GarageSale 6. Tried restarting software and computer which didn’t help. Emailed iwascoding support and did not get a response.

So I uninstalled GarageSale7 and my database uninstalled with it. Have Time Machine backup and found a folder, User > Library > Application Support > Garage Sale. Moved the fold to respective location on Mac hard drive and was able to access my database from GarageSale 6. Upgraded to GarageSale 7 again and now my database is not appearing. How do I get my database to appear and work in GarageSale 7?

Any help resolving this would be appreciated.


that’s very strange :frowning: Are you saying that you made it so GarageSale 7(.0.4?) re-imported your GS6 database but after updating to GarageSale 7.0.5 all your items are gone?

Maybe I got it wrong and it might help to simply re-import your GarageSale 6 database once again. All steps are described in the FAQ here (point 17):

Regards, Kristian

Thank you kristian.

Your solution worked. Point 17 of FAQ did the trick:

How do I re-import my GarageSale 6 library?
1. Export any listings and inventory items you created in GarageSale 7 and want to keep.
2. Quit GarageSale 7.
3. Rename the folder com.iwascoding.garagesale7 in your User Library* under Macintosh HD/Users/yourUserName/Library/Containers to something like com.iwascoding.garagesale7-old.
4. Restart GarageSale 7. In the welcome screen click on the “Import Database” button. This will import your current GS6 database.
5. If done, import any items you exported in step #1.

*Please note: The User Library is hidden by default. To access it click the Finder’s “Go” menu and press the option key to make the User Library show up in the menu. Selecting it will open it in the Finder.

Unfortunately I am now back to the original issue that caused me to lose the library in the first place. None of my listings are appearing in the display when they are selected. I see a current thread on that issue and will post in that thread. Thanks again kristian.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.