HTTPS eBay images

Hello. I’m using my own image server with GarageSale via FTP.

As your topic “Heads up: HTTPS required soon for embedded images”, my server is supporting HTTPS requests (Siteground with Let’s Encrypt). I changed the “Download URL” field with ‘https:’ instead of ‘http:’, but the images continue to be embed on eBay as “http”. How can I fix it? Many thanks.

Hi jaim,

are you using GarageSale 7.0.8?
In the GarageSale preferences > Image Server does the field “Download URL” start with “https://www” ?
In the GarageSale preferences > eBay > eBay Images are you sure your image server is selected?
Also, could you post a link to one of your listings you started after changing the Download URL to https?

Regards, Kristian

Dear Kristian,
thanks for your answer.

Yes, I’m using GarageSale 7.0.8

This is a listing with Download Url changed in “https”, as you request:

Your settings looks fine, however, could you please try if it helps to disable “use passive mode”?

Regards, Kristian

I disabled “use passive mode” and upload again the images, but nothing has changed. Is there anything else I can do?

I am a bit cluessless here. For me it works though but I discovered that it seems to be better to disable “use passive mode”.
How do you “upload” the images? Are you revising the listing? If so, do you make a “full” revise?
Also, this isn’t a listing that you “imported from My eBay”, is it?

Regards, Kristian

Yes, I’m revising each listing using “revise full listing”.
It is not a listing “imported from My eBay”.


this may have something to do with GarageSale’s feature to reuse uploaded images. If an image was already uploaded to one image server, the image is reused.

What happens if you upload a listing with a complete new image (that was never uploaded to your server)?

It also may help so slightly change the image (e.g. crop some pixels) and add this new image and then revise.


Yes, that was the problem! Now it works, finally.

Many thanks!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.