Internal error? No upload possible


Since yesterday, I have problems uploading new listings. I permanently get the error message “internal error - picture upload failed, please try again later”. I am used to ebay problems, but… two days? Is it a Garagesale problem? Any hint would be great, many thanks in advance.

Best regards,


Hi Sabine,

Please let us know which version of GarageSale you have installed. (Just select ‘About GarageSale’ from the ‘GarageSale’ menu in GarageSale.)

This eBay error is returned and generated by the eBay server. There might be a problem with the eBay system but it’s strange that it happens for the past two days.

What image server do you have selected in the
GarageSale preferences > eBay > eBay Images ?
Does it make a difference if you switch to another image server (for test purposes only)?

Regards, Kristian

Hi Kristian,

Many thanks for your reply. Iwanted to try it again this evening before I reply, but somehow I knew it wouldn’t work. - My version is 7.07. I uploaded one item which took a very long time, and when I tried to upload my second item - I got the same error message like the last two days (“Bilder upload fehlgeschlagen . Interner Anwendungsfehler. Bitte versuchen Sie es zu einem späteren Zeitpunkt.”). I have this really weird problem when I use the Garagesale server, my own server and also ebay ESP - the result is the same: Error message and no upload. I have no idea and any hint would be great!

Best regards,


Still the same - I can upload exactly one item (very very slow). Next item and I will get the error message. My third day with this problem.

Let’s see if we can somehow replicate this issue:

What kind of Mac are you using? What version of macOS are you running?

Same here.

I’m currently on v6.9.8 and OS X 10.11.6 on a Retina iMac Late 2014.
Never had this issue before, looks like ebay has changed something in the API…

It takes a loooooong time to get to the second step (“Auktionen bearbeiten”) and then fails with a lot of different error messages. Sometimes it’s an internal error, sometimes the ebay image server, and some more I don’t remember :wink:

The log is full with messages like:

05.03.17 20:02:50,062 GarageSale[446]: -[IHEbayConnector sendImageUploadRequest:filePath:] sendSynchronousRequest returned error: Zeitüberschreitung bei der Anforderung. (data length: 0)
05.03.17 20:02:50,062 GarageSale[446]: GSAddEPSImageOperation received timeout for image at path /var/folders/g7/620p0z0j6_98yt1f4f4bfgjh0000gn/T/GarageSaleTemporaryImages/applemacb-1488740397-6106.jpg

Somewhere between all of these upload errors I found a line where it says:

05.03.17 20:01:15,491 GarageSale[446]: Got error from GetMyMessages: Da das Authentifizierungs-Token unwiderruflich abgelaufen ist, muss der Benutzer ein neues Token für diese Anwendung generieren.

So I tried to renew the token but this didn’t help.
Also I disabled any firewall and established a new connection to renew my IP address.

Don’t know what to do next, please help…


Hi Alex,

I could sort out my problem in the meantime. What helped in my case: I use smaller photos and upload the pics to the Garagesale server - but without using the ebay server EPS as well. Please try it, I hope it will also work for you!

Best regards,


Oh well, today I can’t do anything - no upload possible. I got a new error message: Input transfer has been terminated because your request timed out.

Same here. New listings simply will not upload. I get the message…

“A network error occurred while trying to connect to eBay’s image server.”

Using GS Version 6.9.8b6 (631) on OSX Sierra Version: 10.12.3 (16D32) - MBP 2014

Help would be appreciated sooner rather than later.


1 Like

Me too. I give up for today, I can’t spend two hours for one item. Right at the moment, it’s all a total waste of time and nerve-wracking.

1 Like

Same error here - Multiple variations. Experienced it in the past so likely to resolve itself (may be issue with eBay server).

Running latest Mac OSX & Gargesale versions.

Bonjour, j ai le même problème depuis aujourd’ hui, je ne peux plus mettre en ligne mes annonces !
" erreur interne …serveur d’ images "
J’ ai la dernière version de garagesale 7,0,7
Et j utilise un mac book pro retina debut 2015 version sierra 10.12.3
Merci de votre aide.

Just tried again and uploaded around 12 listings with no issue. Try rebooting and see if that works :slight_smile:

Merci, tout semble fonctionner a nouveau !!!

Exactly the same problem, a few times but last night was terrible. Managed to upload 3 out of 20 listings. Very frustrating.

Seems like this was a temporary issue.
Just tried it again and it works now.


Même problème de mon coté hier soir (dimanche) aucunes mise en ligne possible, c’est vraiment gênant.
de même je me demande si cela n’a pas un rapport avec la mise a jour des annonces eBay (12 photos gratuites dans les annnonces)

In my case, it is NO temporary problem. I can upload exactly one item (and it takes at least five minutes). When I try to upload item #2, it starts again. I can’t work with Garagesale any longer and lose money each day.

Hi sabinesabine,

I am sorry to hear. Did you made any changes to your system recently or installed any network tools?
Do you use any of these tools?:
Kaspersky, LittleSnitch, MacKeeper, HandsOff, cisco anyconnect, GlimmerBlocker, AdBlocker

Also, is there anything non-standard about your internet connection?

Regards, Kristian