Item duplication causes crash

Whenever I duplicate an item in GarageSale it crashes.

Running: macOS Sierra 10.12.3

GarageSale 7.0.7 (795)


This only occurs when I duplicate from the right mouse menu. Does not seem to be an issue if I use edit/duplicate item


Hi David,

Thank you for your feedback.
I just tried it here but duplicating using the toolbar, menu command or context menu worked without a crash here.
I tested it in the Listing section.

If prompted the next time you start GarageSale, please send us the crash report.
Also, can you please open the Console utility and look from output from GarageSale from the time you were trying to duplicate an item?

Regards, Kristian

This is the Console message when I try to duplicate an item. It is the last line of the log.


default 17:57:13.982879 +0800 GarageSale TIC TCP Conn Event [68:0x6000005805b0]: 1 Err(0)
default 17:57:13.982902 +0800 GarageSale TIC TCP Conn Connected [68:0x6000005805b0]: Err(0)
default 17:57:13.982987 +0800 GarageSale TIC Enabling TLS [68:0x6000005805b0]
default 17:57:14.296997 +0800 GarageSale TIC TLS Event [68:0x6000005805b0]: 2, Pending(0)
default 17:57:14.297091 +0800 GarageSale TIC TLS Event [68:0x6000005805b0]: 11, Pending(0)
default 17:57:14.297463 +0800 GarageSale TIC TLS Event [68:0x6000005805b0]: 14, Pending(0)
default 17:57:14.304909 +0800 GarageSale TIC TLS Trust Result [68:0x6000005805b0]: 0
default 17:57:14.589413 +0800 GarageSale TIC TLS Event [68:0x6000005805b0]: 20, Pending(0)
default 17:57:14.589734 +0800 GarageSale TIC TCP Conn Event [68:0x6000005805b0]: 8 Err(0)
default 17:57:14.589764 +0800 GarageSale TIC TLS Handshake Complete [68:0x6000005805b0]
default 17:57:14.590268 +0800 GarageSale skipping upgrade for locked keychain /Users/davide/Library/Keychains/Microsoft_Intermediate_Certificates
default 17:57:14.590561 +0800 GarageSale skipping upgrade for locked keychain /Users/davide/Library/Keychains/Microsoft_Intermediate_Certificates
default 17:57:14.590801 +0800 GarageSale skipping upgrade for locked keychain /Users/davide/Library/Keychains/Microsoft_Intermediate_Certificates
default 17:57:14.591045 +0800 GarageSale skipping upgrade for locked keychain /Users/davide/Library/Keychains/Microsoft_Intermediate_Certificates
default 17:57:14.591285 +0800 GarageSale skipping upgrade for locked keychain /Users/davide/Library/Keychains/Microsoft_Intermediate_Certificates
default 17:57:14.987964 +0800 GarageSale TIC TCP Conn Cancel [68:0x6000005805b0]
default 17:57:14.988012 +0800 GarageSale TIC TCP Conn Destroyed [68:0x6000005805b0]
default 17:57:14.988149 +0800 GarageSale __nw_socket_service_writes_block_invoke sendmsg(fd 47, 31 bytes): socket has been closed
default 17:57:19.274534 +0800 kernel AMFI: allowing exception handler for ‘GarageSale’ (1258) because the process is not restricted.

Can you check if the bug is still there in this version:

Thanks Ilja

It does not crash now but it does not make a duplicate.

In fact the right hand window turns to ‘Nothing Selected’.


PS. Delete works OK from the search window.

The crash in the 7.0.7 release was caused because one or more entries in your database seem to have become corrupted.

So, instead of crashing, the patched version simply skips those entries. That’s why the duplication doesn’t yield any results.

Thanks Ilya.

How di I sort out the database corruption? Can I rebuild it?


That´s hard to tell, because we don’t know if only single records have problems, or the database as a whole corrupted.

Can you export a listing to file, re-import it, and duplicate the re-imported version?

I think my database is too big to export - about 12000 entries. It will only grow as well.

I successfully exported 2000 entries. I guess I could do it in blocks. Can I import more than one file or will each successive file overwrite the current database?

Isn’t there any way of interrogating the database or export numerous listings to a spreadsheet?

Any other suggestions?

Forgot to mention.

When I tried to export the whole database, it crashed and rebooted my Mac.

I tried a second time but I could not get my screen context back. I just went black and stayed there untilI rebooted.


Does it work for you to export a single listing using GarageSale’s export function from the FILE menu, re-import it afterwards and then duplicate the imported listing?

Regards, Kristian

Hi Kristian

I can export a single listing then re-import it.

It creates a new listing leaving the original but it does not know which group it belongs to.

If I have to export 12000 items it looks like I will have to delete all existing listings (to avoid duplications) and then the whole 12000 will be in one big list. That would take me days to re-order and I am not sure I want to go down that track.

Can I interrogate the database directly? Is it accessible by mysql or similar?


Did you try to export in smaller batches, e.g. 100 items at once? Does this work?

HI Ilja

I said in an earlier post I can do this in much bigger batches and re-import them in the same number but it is a fair amount of work because:

  1. when they are re-imported they are imported into one long list (groupless), which means I will then have 12000 in a single group less list to be re-sorted. Not sure if I could face that.
  2. I then have to delete all the originals to remove any corruption that may exist in them.
  3. I may not know until all 12000 have been imported whether it has made any difference.


I’m having same issue too after updating to GS 7 about a month ago.

Same version as OP 7.07 (795). Sierra Macbook Pro late 2016 base model

Hi Mark
If it is possible to corrupt the database, which is obviously possible and that’s ok, then it would be really useful to have a utility to validate the database as well.

Regards David

Hi Dave,

I had some trouble importing when I first upgraded to V7 - so I manually copied stuff over to the directory from an old back up. It worked fine for a few weeks - and then all of a sudden this week it crashes every time I’m using GS. Right now it’s an inconvenience and I just relaunch. I don’t have time to look into this. I do hope they come up with a fix and release a bug fix update.

Don’t hold your breath, Mark.

Don’t gert me wrong, I really like the app and I can also work my way its problems, but every release seems to introduce new bugs and there are still outstanding requests for improvements from years back that have not been implemented.