My Legacy Media Browser is Empty and Broken HELP

Version 9.0.5. user here, and NOT a user of the Photos app on my Mac.

I’ve been using the Legacy Image Browser since my photos are outside of the Photos app, and have been very happy - but it seems to have stopped working.

Up until recently, the Image Browser would show the content of the 'Pictures" folder and the subfolders & files within. I could merrily jump around and find every picture I needed.

Today, the Image Browser showed only the content of the last folder of pictures that were used (let’s call it “BOOKS” with 12 images). There was no way to exit and select other files.

I went into Finder and deleted “BOOKS”, hoping maybe that would cause the GS Image Browser to show other folders/files in my “Pictures”, but no luck.

Now my Image Browser shows nothing at all, and I can’t figure out how to direct it to my “Pictures” folder.

Can anyone suggest a fix, please? I’m stuck now, and unable to list anything since I can’t insert pictures.

Could you maybe post me a screenshot of your Media Browser so we can see what you see?
Taking screenshots is done easily:
Press Command-Shift-4 on your keyboard simultaneously, then select an area with the cursor. It will be saved as an image file on your desktop.

If you don’t want to post it here you can send it to me directly (click on my avatar image) or contact me through the GarageSale support:

What version of macOS are you using? Did the Media Browser stopped working after you upgraded your system?

Regards, Kristian

Thanks so much for the quick response! Below (I hope) is a screenshot showing my empty Media Browser. I’m running MacOS Monterey 12.4.

I didn’t notice anything happening after an upgrade. (Could be, but I just didn’t notice).

There’s one event that is possibly connected. Before shutting down my computer one night, I went into Finder and deleted out a bunch of photos in my picture library, including folders that had been used that evening in Garage Sale, then shut down my computer. I didn’t use GS for a few days after that, but the next time I opened GS the Image Browser was stuck in the latest folder of pictures and couldn’t be changed.

Thanks for your help!

Make sure legacy Media is still checked in the preferences

Yep, it’s checked. I also tried unchecking it, restarting GS, re-checking, & restarting GS again. No luck. Thanks for the suggestion, though.

Mine lost its path once and I cant remember exactly how I found it again. Make sure the everything leads to the folder where your pictures are being stored.

I can’t seem to find any way to point the browser anywhere. It’s just an empty void. If you know of a way to get it pointed to my ‘Pictures’ folder, that might solve the problem.

Can you find the folder where the pictures are being stored? Try drag and drop into the media screen panel or use the search in the bottom right. I think once you establish the path it establishes it in the future. Mine has every picture that is in Photos

Another good suggestion, but I’ve already tried that as well. I can drag my “Pictures” folder onto the media window, but it doesn’t stick. I also tried going down to a more granular level and dragging only one picture in, but it also failed to drop.

Before this latest adventure, I was also able to access everything in my Pictures folder. Problem seems to be that I don’t have a way to point the legacy image browser in that direction (or any direction, for that matter).

Thanks, though, for trying to help!


I’m not sure what happened, but when I opened GS this morning all of my pictures were visible in the media browser.

As a bonus, both the “Pictures” folders AND the “Photos” photos library were accessible.

So, no more problem…although I have no clue at all as to what fixed the issue. Thanks everyone for your suggestions.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.