New "Ghost Listing" issue

This morning I’ve generated about 180 “ghost listings”. I’m not sure when exactly they appeared, but here is the process I was doing when they did appear, which is exactly the same process I’ve been using for about 4 weeks with no issues until today:

  1. I have a Smart Group that indicates listings I can restart (my criteria). I selected that Smart Group
  2. I run an AppleScript that randomly tags 30% of those “red”
  3. I have a different Smart Group with the only rule being “listings tagged red”. When I run the script in (2), the correct number of listings appear in this folder, and when examined they are tagged red. This has been working fine.
  4. I stop the red-tagged listings, edit them in several ways, and start them again. I select “move originals to Trash after duplication”. NORMALLY THIS IS FINE.
  5. When they are all launched, typically select the items in the “red folder” and untag them. Today I noticed that the number of items in the folder had weirdly changed while I was launching. Eventually I noticed that I had somehow created 176 “ghost listings”, all tagged red.

These have no attributes whatsoever: no pics, no title, nothing to see or grab in the user interface. They do not appear to be “anywhere” in the GS interface: they do not appear in the Trash, or any other group, or the root browser. They only show up in the “tagged red” Smart Group.

Amusingly, they don’t even have a red tag in the interface. They have no visible tag; they just take up empty rows.

I can select the rows (all blank) and start a Drag event, and it shows the indicator count of the correct number of rows I “am dragging” but they cannot be received by the Trash or any other folder. That is, there is no “+” when I drag them over any container.

I thought, “hey there might be a problem with the smart group” so I deleted and rebuilt it… and no. A new smart group finds the 176 red ghosts again.

I have rebuilt the database, and also tried “remove ghost children” but they still appear. Right now I’m rebuilding the index.

Because these “red ghosts” only appear in that one smart group, I can hide them by adding a new rule, like “status is not ended successfully”, and they will not appear there. But when the secondary rule is disabled, they are still there.

I’m rebuilding the index now. Will let you know how that works.

100% confusing fix:

The “red ghosts” were still present after cleanups. I was about to shrug and learn to live with them, so I was going to edit the Smart Group they haunt by adding back in the trivial rule like “status is not finished successfully”. I noticed that the Smart Group did not have an order specified.

I selected “order by title”.

They disappeared.

I turned off the order selection.

They are not there any more.



I suspect what might have happened was that I attempted to “change color tag” using the dropdown while the listings were being launched, resulting in a weird race between duplicate-and-move-original-to-trash and the tag dropdown.

And I think it might have actually been fixed by one of the mysterious checkboxes in the launch diagnostic window, but that the Smart Group showing the ghost items just didn’t update until I clicked it and redefined it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.