Problems with hosting images on my server

I can’t host images on my remote server.

Steps to reproduce:
GS>Preferences>Image Server.
Connection type: FTP
Enter server details.
Click "Test Settings"
This gives an error: remote chdir failed.

Then try:
GS>Preferences>GS FTP setup assistant (with setting “FTP”)>Continue
The directories on my remote server show up.
Select desired remote folder.
Click Continue.This uploads a test image to the desired remote directory.
Then error message appears the image cannot be downloaded.

It appears that uploading with the GS FTP setup assistant works but that using the same image path in the >Preferences>Image path window fails.

I suspect a bug in GS here.

PS1 My remote server is perfectly accessible with the Transmit ftp software; copying the paths from Transmit to GS doesn’t help.
PS2 Looking up paths via >Terminal>ftp as suggested in the GS Help isn’t possible anymore because Terminal>ftp was kicked out of >Terminal in High Sierra for security reasons.

Any suggestions how to tackle this problem?

Have you tried to test launch a listing with only a single image?

Some providers don’t allow multiple FTP connections( which GarageSale uses to increase upload performance). So when the second FTP connection is opened, the remote FTP server returns an error.

Yes, that also gives an error “remote chdir failed”. The remote host is “WPX hosting”, they support multiple FTP connections.

This sounds like it is a unix permission problem on the server.

Can you post a screenshot of your FTP configuration in GarageSale? Most interesting would be to see what path you have configured there.

Attached pics of FTP settings (also of other FTP program which connects fine).

Does it work if you just enter “eb/” in the “Image Path” field in the GarageSale preferences?

The image path field is wrong.

You should enter the folder path where your images are stored there. Basically that’s he path you need to drill down when logging in with your FTP client to get to the “eb” folder. My guess is that it is something like “html/eb/” or “eb/”. Hope this helps…

YES that worked! It should be /eb/

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.