SERIOUS communication problem

I am having a serious problem with GS7. I have even tried installing up to the latest beta version without success.

I have REMOVED and uninstalled GS7 and did a clean install. This problem exists on my system even with a clean install.

  1. I can install and run the application without issue.
  2. I can add my ebay account which then adds a token.
  3. I can download the categories by selecting the gear icon.

That much works in regard to communicating with eBay. I can see the access token from my eBay page being valid for the 3rd party access. The token is fine.

What does not work:

  1. File->Import-> Import From MyEbay
  2. Clicking on the button next to the Account Details: label that reads “Update Account Details”

If I try either of those options GS will just hang, forever.

I am running High Sierra.

I can not use GS at all at this point. I initially discovered the issue when trying to list a new item (with the last install of GS 7 which WAS working previously) so I tried everything and then got to the point of being so frustrated that I did a full APP Remove with an App Removal App to make sure it removed everything so I could do a clean install. Unfortunately, the clean install does not help.

I don’t understand why SOME of the communications work but not others – perhaps the communications routines are different for these various aspects. It does seem the OAUTH stuff (via browser) works but not the internal communications.

I have looked at the console output and there is a mess. It complains that it can not read the token yet it shows it in the app and can even be refreshed (the refresh works).

I am not going to post all the console data here in my initial post but I think this might be of value:

*** Assertion failure in +[IHEbayConnector standardEbayConnectorForToken:forEbaySandbox:], /Users/ilja/source/GarageSale_7/GarageSale/IHEbayConnector+StandardEbayConnector.m:118


On first glance, that sounds like a Keychain access problem to me.

Have you tried opening the Keychain Access utility and removing all entries of type “GarageSale eBay Token” (you can use the filter field in the upper right corner)?

Then run through the Auth process in GarageSale again, and verify that a new Keychain Access entry has been created. Check the Access Control settings for the newly created Keychain entry to make sure that GarageSale can access it:

If this didn’t help, it might also worth be trying to delete the Account.leveldb directory from GarageSale’s library folder. (In GarageSale, Help menu > Show Library Folder).

If you still have the crash report, please send it to our support e-mail address at garagesale AT referring your post on this forum. Maybe it’s possible to prevent that crash and show an error message instead.

Yes, in fact it was a keychain issue. The funny thing is that I have had no problems at all with any other applications up until this point.

I looked in the keychain and in fact there were ZERO “GarageSale eBay Account” entires. No matter how many times I did a clean install or tried other solutions GarageSale just did not seem to have permissions to write to the keychain for some reason. VERY ODD INDEED.

The solution required me to basically rebuild a new login keychain. Once the system generated a new keychain file the next token request actually stored in the login keychain. The application is working perfectly now.

I am an engineer/programmer of 30 years and I had a tough time resolving this issue. Others with less experience would have never even probably seen the console entry at all and possibly spent days trying to fix it once tech assistance was provided (if they even bothered to ask for it). So I have a suggestion…

In your application when adding a token to the keychain if it is NOT actually successful at install time, perhaps popping up a modal box and informing that user that the keychain update failed might actually be a good idea? It would have saved me 5+ hours of work trying to solve the problem. From just looking at your application it indicated that the token was updated (as I am sure this is stored in your own DB) so there did not appear to be an actual error – where the keychain was never actually updated and in fact failed. So it APPEARS to be successful when in fact it is not. That does not make for easy troubleshooting.

Thanks for the help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.