Smart folders problem

I have a terrible time trying to resolve this issue on my own, so I really need help here. I used to work with smart folders all the time, without them I really can’t imagine managing 1000 of items. Before I never had problems, now (I moved my database from another computer) it’s completely confusing:

  1. I have listings on three websites. When I relisted I used a smart folder with “Website is …” and “Status is ended unsuccessfully”. From there I used to select the listings in that currency and resist them with ease. Now the smart folder is showing that I have 187 listings, I start editing when I realized that I see dublicated listings. I clicked on one of those listings and the folders is showing “Nothing Selected”. When I try to open the listing or start it, the program is crashing. I found that if I click “reveal Originals” sometimes I can work with the selection, but most of the times, when I have a lot of, as I call them, “ghost listings”, it’s not working.

  2. Sometimes I try to select let’s say prepared listings in USA and it’s showing me mixed USA listings, so I start manually picking the ones I need, which is almost impossible for me to do.

  3. I spent the day cleaning doublicated listing ( I have a structure of folders and subfolders, so the Arrange by Title is working, but only on a sub level , so cleaning those took me several hours. Just now, when I tried to make an event, the program asked me to duplicate the originals and then to throw them in the Trash, I saw how at least 100 listings stayed untrashed and here I have again many listings to clear. I went to the smart folder I used for the event, selected all the black listings, so I could clear the Originals, after clicking Reveal Originals, the smart folder went “Selected 1 listing” not 87. :frowning: I felt totally desperate.

  4. Some listings are not shown properly, for example an Ended Successfully listing is presented as black one (not in the smart folders, in general) and from there many problems arise.

I am completely dependent on the smart folders in the moment, I previously I never had problems with them, those are just amazing. What happened, since I moved the Library everything is a mess? I really need to make it work flawlessly as before, please, advice. :(((

P.S Sorry for the multiple posts, but I am working with the program at least for 3 years now, do not understand what I did wrong, I checked everything I know. Thank you!

When you re-opened GarageSale, did you fill in an e-mail address in the crash report panel? If so, was it the same you are using on this forum?

Maybe the database indexes are got out of sync somehow. When starting GarageSale, hold down the ctrl-Key on your keyboard. In the panel that appears, check the “Rebuild all indexes” option. This may take a while to complete. Once GarageSale is fully running, go into each smart group rule window and hit OK to update the smart group contents.

I had many crash reports send without describing what happened, I filled some, but not with the same problem. It just crashed several times now, trying to revise the store categories, to resist items, even when I select a single item after selecting few others. I will try what you just suggested, even though I didn’t understand very well. I will start filling all the crash reports from now.

Nothing is happening when I hold down the ctrl-key, tried couple of times.

Start GarageSale first and (still during the startup process) immediately hold down the ctrl key on your keyboard.

Yes, tried that. Nothing really changes or appears. The start up process is just a second or two, maybe I can’t catch the moment. :frowning: Edit: Started the process, will see what will happen.
The second big problem is that the program is crashing when I try to fix the store categories, and the store is a mess. Do you think if I delete the program and install it again, it will help?

All indexes fixed, there are still “ghost items” and non-behaving smart folders.

For example, right now I created a smart folder for Ended unsuccessfully in UK. The folders is snowing me 56 items for relist, but when I actually start to check them one by one, 53 are not existing in the database? There are actual 3 items for relist. The program is seeing the items as ended, when they are running.
Sorry for the trouble!

I really don’t understand what is going on with my database, now I go to a folder, select use store, and then one or two categories for the items in there. Then go to couple more folders, and when I return to the previous ones, use store is not selected and the changes I made are not there … Tried couple of times. It feels like there is someone who is deselecting the options I choose, how is this even possible?

This sounds to me like write operations to your database are failing, which could indicate a corrupt database. Do you perhaps have an earlier TimeMachine backup you could revert to?

Not really, only the one I started with. With our business, older databases are not useful because we never sell identical items.

Do you think a structure of folders with three levels could cause the problem? Before, we used to keep batches with around 100 items in a separate folders, so 10 big folders with 100 listings in each. Now I am trying to replicate a store structure. I don’t think it is that complicated for the software to get confused, but I thought about it.

About the store categories, after some tests, I figured that they won’t change if I revise them immediately after changing and the software is now crashing less, just because I changed Revise – Store Categories with Revise Entire Listing. For the moment I am revising the new categories, hope they will stay.

But the Smart Folders are not getting any better, just created a Smart Folder to show me which items to relist in UK, showed me 56 items, after Reveal Original, there were only 3 real listings, all others were Ghosts. Same happened when I searched for particular listing in the database, showed 2 results in the Search Results, one real, one not - both active.

1 Like

We fixed a couple of smart group related bugs in this build. Let me know if it works any better:

I am working on something that may resolve the issue, not sure yet. I will try that in a few hours too. Thank you, I really appreciate your help!

Hi Ilja,

I too have many Smart Group issues.

I’ll give this version a try.
Can you give me a bit more detail on “smart group related bugs in this build” so I know what areas to look for?


Yes, I saw your post, but didn’t have time to respond to it yet.

The main bug was that the smart group list didn’t always update when hitting “OK” in the rule editor. Not sure why we didn’t catch this before. :pensive:

OK, Great! Good to know.

The version you provided me didn’t change the problem with the Ended unsuccessfully listings, but I found that the problem may not be the smart folder. I saw that there are exactly 53 items in UK and 9 i DE which were showing as black, and all those were the ghost listings. When trying to Reveal Original, nothing would happen --> Nothing selected on the screen or the program crashed, but when I pasted the full title in the search box, I saw the listing and above it ,the original which was running. I did noticed that the Ghost listing is editable, so I deleted it manually and it disappeared from the smart folder. So i manually searched and deleted all of those, until there are none left. It seems that those listings were in a directory not visible nor accessible through Smart Folders, and that was the reason for not being able to locate and delete them. Now, it all seems better, all Smart Folders are working properly and updating the categories is fine now. Thank you for your support and your great software! :)))

The problem with the folders persist. I have a smart folder with 7 items to relist. When I hit show original the folder won’t show anything. :frowning: edit: or crashes. It seems only the ended listings are trouble makers, the others are working just fine.

For the other Smart Folders is the same, Prepared Listings --> Reveal Original —> Nothing Selected. I can barely work like this, I hope there is a solution.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.