Some annoying GS9 bugs

This happens on a brand new database with listings manually exported from GS8 and reimported to GS9. Ebay accounts and settings were re-entered manually as well.

Cannot enter numerical values with a comma for price and best offer, this also affects fixed price (instead of percentage) offers sent to watchers. In the latter case, entering a value with a decimal point like 79.99 for an item with a Buy It Now price of e.g. 99,90 results in ebay giving back error that the offer price is higher than the Buy It Now price, so it seems like ebay treats “.” instead of “,” like a digit grouping separator (or thousands separator) instead of a decimal separator.

This also affects Starting Bid and Reserve Price values.

Screenshot 2022-05-04 at 13.49.42

Also, sometimes the “Advanced” and “Properties” tab in the listing view disappear, but reappear after restarting GS9.

You can also make “Advanced” and “Properties” reappear by making your window a little wider.

What version of macOS do you use?
Also, did you maybe make changes to currency/decimal settings in the System Preferences > Language & Region > More Options?

10.15.7 (19H1824)

no change. GS8.4 doesn’t have this problem on the same system. System language is set to English, decimal/date/time formatting etc. set to OSX built-in conventions for Germany.

Screenshot 2022-05-04 at 14.50.58
Screenshot 2022-05-04 at 14.51.12

Resizing the entire window did nothing, but resizing the inspector pane did. Still, this shouldn’t happen.

You are right, I meant resizing just the inspector pane. Sometimes multiple times a day and sometimes once a week.

entered “12.24” manually:
Screenshot 2022-05-04 at 20.07.22

Screenshot 2022-05-04 at 20.07.26

this is what ebay responds with (used a period as a decimal separator):
Screenshot 2022-05-04 at 20.07.33

and this happens when entering a number (like “12.24” with a comma as a decimal separator:
Screenshot 2022-05-04 at 20.08.09

also there’s a bug with the minimum percentage, ebays actual requirement is >=5% as the offer price, not >=6%:
Screenshot 2022-05-04 at 20.09.00

entering “11” instead of “11.00” works
Screenshot 2022-05-04 at 20.09.49

Can we have this resizable at the red arrow? The message field doesn’t need to be resizable at all since it’s limited to 230 characters anyways…

More bugs:

When duplicating a listing to fill the new one with info, the popped-out Attributes window doesn’t show the attributes corresponding to the new category selected. The Attributes window has to be closed and reopened again (what a PITA) to show the correct attributes.

There was indeed a category selected for the item in this screenshot, but i bunged up the highlighting box. Didn’t mean to censor the category :wink:

Also can we please get rid of GS opening MANY popped out windows (mostly best offer settings in my case) that weren’t open before when GS is restarted?

I could not reproduce this here easily. Do you have any steps to reproduce this? Do all the windows of an earlier session just pops up? Which macOS version do you use?

GarageSale saves the open windows in a key called detachedPopoverWindowControllerInfos. Between sessions, you can read the windows that GarageSale should open with

defaults read com.iwascoding.garagesale9 detachedPopoverWindowControllerInfos

in the Terminal app. Are there informations about all open windows or does GarageSale opens more windows?

I could not reproduce this one. Can you make a short screencast about this issue? When I duplicate a listing, the detached attributes show the same attributes (as they were duplicated). After I change the category, the new attributes appear in the popup (so I can add them).

I have also had the mysterious popup window open on launch happen OCCASIONALLY over the past many months/years. In my case, it is only one detached popup window (usually the Best Offer window, I THINK - which I never have open) that opens… Can not figure out a rhyme nor a reason…


I’ll try to remember to do this command when the window opens…

[Neals-iMac-2021:~] neal% defaults read com.iwascoding.garagesale9 detachedPopoverWindowControllerInfos
[Neals-iMac-2021:~] neal%


You have to call this in between launches, e.g. before you start GarageSale. We have to find out weather either the detachedPopoverWindowControllerInfos is not properly updated and GS opens the windows or if macOS decides to restore them because it thinks the user may loose data. If the detachedPopoverWindowControllerInfos array is empty, its most likely a macOS failure.

This is a years old issue. It appeared when GS introduced the possibility to move the pop-up (like shipping one) and create a separated window which always stays opened (the window with red-yellow-green icons I mean). This bug happens after launching GS when you previously (before quitting) tried to insert profile shipping (in my case), GS didn’t save the profile, tried again to open shipping pop-up and GS opened a separated window instead of a pop-up (don’t know if this is explain properly, sorry…). When you launch, you will see as many windows as many times GS didn’t recognize the profile and you had to open again the window.
This is quite hard to explain, this is why many times I gave up to report, sorry for my negligence…

Indeed, i reported it maybe 2 years ago but nobody cared.

Same as with the renaming bug. Even older but still not fixed.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.