Testing "Photos-to-GarageSale" drags

Hi there,

here is an interim release of GarageSale that should fix direct images drags from the Photos window to GarageSale’s listing preview. If you are interested in getting this feature to work, please take this version out for a short test drive:



Just tried this update and one can still not drag and drop from Photos Version 1.0 (209.52.0 to GarageSale Version 6.9.5 (612). Only way to get it to work is to drag and drip from Photos to Desktop (which converts it to a jpeg) and then drag and drop into GarageSale. Not a desirable process.

Also, noticed in this attempt to fix the drag & drop from Photos to GarageSale, the Media Browser Window always reverts back to the GS application window. Have a dual monitor system, and yesterday’s version would allow you to drag the Media Browser to a window on the second monitor and it would stay there even when going to another window on the second monitor. With this most recent “fix” it reverts back to display on the GarageSale App window on the first monitor.

Thanks for getting back with me on both issues. Guess this one is taking longer than we thought. :frowning:

Can you please check if this version fixed the drag and drop from Photos:


YES the drag and drop from Photos now works!! Thanks. The dual monitor media browser issue previously reported is not resolved but for me that is not an issue since I always drag & drop from Photos. With over 27,000 photos it is almost impossible to find particular photo events in Medial Browser, but is easy to do so in Photos.
Thanks again for resolving the issue with Photos.

Can you please give me more details on the dual monitor issue? I could not reproduce it by moving the window to another display, bringing Safari to front, and switching back to GarageSale. Media browser was still on the same position.

Any ideas what I’m missing?

Just tried it again and here is what happens. I have GS on monitor 2. On Monitor 1, I have Desktop sessions 1,2,&3 active (the kind you have to 2-finger swipe between using the magic mouse in order to toggle between on monitor 1). I select Media on GS monitor 2 and it opens on GS Monitor 2. I then move the media browser to Desktop session 4 on monitor 1. I can toggle fine between the Media Browser on Desktop 4 on monitor 1 and GS on Monitor 2.

The issue happens when I go to another Desktop on monitor 1either by 2-finger swiping or clicking on an application that is running on another Desktop within monitor 1. At that time the Media screen goes back to monitor 2. Prior to the attempts to fix the photos issue this did not happen. i.e. you could toggle back and forth within within desktops on monitor 1 and the Media screen would still be on monitor 1. Let me know if you need any additional clarification. I am running an iMac (early 2009) with an attached new (2015) Samsung monitor.

There is still an issue with Photos. It happens when the first photo you try to drag and drop is one that was converted automatically from iPhoto. You get this error:
“Export Complete with Errors
0 of 1 file have been exported to GSDraggingUtilsPomisedFiles
The export operation failed to create a file for th photo identified below:
IMG_5102.JPG - Could not write to destination (1,016)”

Here is the interesting part. If you subsequently drag and drop a photo that was created AFTER the conversion from iPhoto it works! Furthermore, you can go back to a photo that WAS converted from iPhoto and NOW it works!!. In other words, if you first Drag and Drop a photo post-conversion from iPhoto, everything works fine.

Thanks for the explanation. We’ll look into this, but I cannot promise a fix.

Hi, drag and drop from Photos is not working for me. What is wrong?