Texts formatting

some weeks ago we discussed about problems with text formatting but if I am not wrong that discussion was closed. I think you should keep it in consideration, it is starting to be really annoying. Every time I write a word with ’ (apostrophe) and I click on space all phrase becomes smaller and looses formatting (f.e. bold disappears, space between phrases becomes smaller, sizes too and so on). This is (and was with GS 6) a weak point… what do you think?

i think developers did not know how to fix this because this problem migrates from version to version since 6.x
i spent SO many time just to format my descriptions so all of them looks identically. and this is almost impossible to do.


I just tested it here in GarageSale 7 (Preview Mode) but was not able to reproduce the described issue so far. Can you reproduce it with a newly created listing? If so, how?
Also, feel free to export one of the listing in questions and attach it to this post so we can have a closer look at it.
For me it sounds more like an issue with probably corrupted/invalid HTML code :confused: but maybe I am wrong.

Regards, Kristian

Hello Kristian.

HTML code that generates GS for formatted text contains too many unnecessary tags. i think that is the reason. and may be it interfere with theme html code.

I don’t think that this causes the described issues.
Can you reproduce the issue with a newly created listing? If so, how?

Regards, Kristian

Hello Kristian,
I will do it as soon as possible. I remember I did a video to show the matter… you can find it here

Continuing the discussion from Fonts bug - restores to arial

This is just one of different problem with formatting, I will check with my listing and then I will export one.

Thank you

Thank you for sending me your listing. I tried it with your listing and did the same shown in your video but I was not able to reproduce the describe issue. Could it have to do with the default settings of your own custom HTML design template? Sorry, I am a bit clueless here.

Regards, Kristian

i do not see that video, but as for me - i’m using pro.eco and pro.topseller templates. both has the same problems.

Can you reproduce the issue with a newly created listing? If so, how?

with GS7 i tried to delete whole available html from editor mode and paste unformatted text and formatting it in WYSIWYG mode. at some point of formatting process listings begin to reset fonts and line height.

with existing listing it is even enough not to edit description but to switch back and forth menus, and other listing options to reset fonts to arial.

will try to reproduce step by step.

Using GS7 I am having a similar problem: items tabbed to form a table are not working. When I switch back and forth edit and preview mode I get text with html tags and a unusable mess.

Formatting issue is always there…

If you want to use table in your listing description, I suggest you enable Markdown conversion in Editor mode and stop editing your listings description in Preview mode.

Here is what to do:

  1. Create a new listing
  2. Switch to Editor mode
  3. Below the description field, choose “Convert Markdown to HTML” from the Description Conversion popup

In your description, enter something like this

Column A | Column B | Column C 
A        |    B     |     C  
D        |    E     |     F

Now switch over to Preview mode and check how it looks. Easier than those HTML tags.

Thanks. I will try with future listing.

Ok, so I cleared the text in a running listing template. I followed instructions for markdown to html. Bold works. Line breaks work. Table does not. I also got some magenta colored text in between “** **” command. Text is black in the listing preview.

Can you send me the listing you are working so I can have a look, what’s going on?