"An image upload operation returned, but didn't provide an image URL"

I just relisted about 25 items from GS6 earlier today, no problem.

Two newer ones I created in GS7 are giving me problems - no images. I tried removing, then adding the original images, but still got the message “An image upload operation returned, but didn’t provide an image URL”

Phone: No gallery image, but all photos are in the Item Description
Browser: No images at all

232660578775 and 232660578779

P.S.: where did the upload image option go for this topic?

It’s the same: Strange warning

Using 7.0.9 - no problems noted in Preflight

I know, fedege96, I saw your question, but didn’t tell whether your problem was solved… Mine is set up exactly like yours, too.

Don’t understand why all the others I relisted from GS6 were fine! The only difference is the account I used.

:slight_smile: thanks for your reply!

P.S.: still missing image upload function.

Welcome, I guess it does not depend on GS but on ebay side, I never saw it before and never said again later (at least until now)…

I am also getting this message … started the last couple of days. I’m trying to do bulk resist and this message is coming up for half the listings (overtime it comes up it puts a halt on the whole relisting process which is making the job longer and harder). I have to then attempt to try again with those listings and they usually upload fine the 2nd time. Its happening on new listings for me too. Anyway to fix before I go even more crazy? I am using version 7.0.10a1.
Thanks for any help!

sorry, I guess I don’t need to go thru uploading images, just paste or drag and drop…

Here are some of the things I did look into on the ebay side:





Notification (Above ^^^^) “Found non-secure (HTTP) content…” image above

As follows:

the same problem with revising my 150 listings. appeared about a week ago. now each 5-7 listings.

Did you already update to GarageSale 7.0.11?

I am asking because eBay made changes to their picture service upload which are covered by the update.

Regards, Kristian

i have no 7.0.11 in autoupdate :frowning:

Please let us know which version of GarageSale you currently have installed. (Just select ‘About GarageSale’ from the ‘GarageSale’ menu in GarageSale.)

What exactly happens if you check for updates?



kristian, I know you’ll probably be along sometime tonight, but when can I expect some kind of resolution on this?

Quite GS and reopen, then check updates

Hi Laurel,

unfortunately, I don’t know why the update function doesn’t work for you.
I also tested it with GarageSale 7.0.9 and it worked like a charm.

However, you can always download the latest GarageSale version from the GarageSale website directly:

Regards, Kristian

That warning appears if I open the “check updates…” from menu and close it without updating. Next time I click “check updates…”, that warning appears.

My suspision is that these error message have to do with eBay’s new image upload system, they have been rolling out earlier this month (or are perhaps still rolling out).

If you are still getting the “An image upload operation returned, but didn’t provide an image URL” error message box, here is a link to a GarageSale release that tweaks the retry strategy used when uploading images to eBay. More specifically, this version will retry uploading an image to eBay if the eBay returns no error code but doesn’t provide an URL to access the uploaded image:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.