Applescript error

I ran an applescript today that I used in January. It worked great so I saved it. It now returns an error. Any ideas? It was an applescript in the list that I changed to increase prices 6.5%. The applescript returns a counting error but I don’t see a counting request. The red shaded area is highlighted with the returned error.

You made more changes to the script, e.g. inserted these “class GSsl”, “class GSbn” classes and you ‘tell application “AppleScript Utility”’. Maybe these changes are causing the trouble now somehow?

Regards, Kristian

I changed The default answer from 100 to 106.5 Thats all I changed.

I tried the original from the GS dropdown menu of Show applescripts examples. It returns the same error. What do I need to remove?
Screen Shot 2021-07-02 at 2.54.17 PM

I found a copy I saved in another folder. The problem was "‘tell application “AppleScript Utility”’. I changed it to “Garagesale 8.3.6” and it works again.
Screen Shot 2021-07-03 at 7.59.51 AM
I don’t know why but all the applescripts say “AppleScript Utility”’ when I open them.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.