Bug in GS 8.1.1 b4 - Unresponsive GUI when selecting multiple Listings

Bug in GS 8.1.1 b4 - Unresponsive GUI when selecting multiple Listings

see attached screencapture

Since the beachball cursor is not always captured in screen captures, did it show up while GarageSale was unresponsive?

Nope, it’s just the GUI that doesn’t respond or update, the main window can be dragged around by cursor and GS still can be quit normally (like i did in the vid, pressed cmd+Q, then enter, GS quits as expected, just didn’t show the contents of the quit popover as shown in the vid).

Could you please invoke the “Run Spindump” command from Apple’s “Activity Monitor” utility on GarageSale, right before you start selecting multiple listings.

The output of that command might be helpful in diagnosing the problem.

Absolutely, i’ll try right now.

Here you go, let me know if that worked.

I was able to isolate the problem, it only happens when selecting ended listings (marked solid grey).

Spindump_GS_1.txt (6.3 MB) Spindump_GS_2.txt (5.9 MB)

Sorry, I could not reproduce the problem (selecting multiple ended listings in ‘Live’ mode), nor did the Spindump files show any blockers in GarageSale.

What popovers do you have open at the time this happens? Hard to see from your screen recording.

I’m guessing you have already tried this but just in case…The spinning wheel does not always appear automatically. Sometimes you have to move the cursor over the GS screen to make it appear.

Best offer, Attributes, Payments, Shipping

Any news? Really not too keen on having to work around this.

I also wasn’t able to reproduce that issue. At around 0:06 you switch to Preview mode using a keyboard shortcut. At this point an error icon is displayed next to the start button in the toolbar. If that error still appears, what does it say if you click on it? Is it a token/keychain error maybe?

Regards, Kristian

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.