Can not list ANY NEW items - get Error 10007 "Internal error to the application"

Everything has been working Great until starting yesterday I can no longer list any NEW items.

I get an Error 10007 “Internal error to the application” for every photo in every new listing I try to start. Re-listing still works fine.

I have 1200+ active listings (17,500+ total templates) in GarageSale Version 6.9.8 (632).


Now, Re-listing also gives the same Error 10007 “Internal error to the application” for every photo in the listing I try to re-list… :frowning:


Sorry, to hear that, but I guess that’s been the final nail in GarageSale 6’s coffin.

Has anyone called ebay about this yet? last month I figured out it was because of the images in GS6 giving the error. I had to switch who was hosting the images so that the images have https connected to them instead of http. I also had to get rid of ALL templates and set to None and I had to get rid of all images in descriptions and set to No images in description as well. Which was fine with me cause I like simple and short in descriptions. That fixed it but now it’s something else ebay is crying about in GarageSale 6. I will call ebay tech and ask. I want to know what their problem is now. UGH!

The best way to find out is to look at the actual html code on one of your ebay listings from GS and see which code is flagging it. Then go back to GS and get rid of what ever is giving the problem in the listing from GS.



Just wanted to let you know that I contacted ebay through facebook the other day about this issue and this is the response which wasn’t much help. So yes I switched to Garagesale 7 and it has been a big change but I’m not getting that error message when I list anymore.

Good luck to you!

GarageSale 7 is broken in OSX 10.10.5 and doesn’t show thumbnails. I will not upgrade my OSX to 10.11… it’s got way too many bugs. my whole family is pulling their hair out with 10.11 … they all downgraded back to 10.10. I am really disappointed in all this.

macOS 10.13 is the current major of OS X. Whatever bugs you were running with the macOS 10.11 release, there’s a good chance that have been fixed before.

Actually, we are not offering the thumbnail view for 10.10 because of bugs in that specific version of macOS.

I have el capitan on 3 macs, no issues. apple does frequent updates to work out issues.

I an having the same issue with listing new auctions. However i can re-list without getting the error. What is the cause of this 10007 error? I know its on the ebay side but why.

I called ebay Application Support team, she was very helpful and said the error is hard to figure out on their end. It could mean anything from server down to application conflicts. She suggested other ways to bulk list (File Exchange, Turbo Lister and the new Ebay Seller Hub) but they ALL have one thing or another wrong with the applications and doesn’t support everything GS does.

I bit the bullet and ended up upgrading to High Sierra. It was Sierra (not High) that was giving us all the problems with bugs so I guess High Sierra is fine now. I had to upgrade to GS7 to get everything working again. I lost 3 applications due to non compatible with High Sierra (exactly what I was afraid of) now I have to get those programs again.

I just upgraded to GS 7.0.13. I can list now but I have a bunch of questions that ill start on a new thread. Thanks for responding so quickly!

That’s not error on eBay’s end. They replaced the interface that GarageSale uses, with something new. We had to rewrite parts of Garagesale 7 in order to stay compatible. The support rep just doesn’t know about it, because GarageSale is one of the very few third-party apps using that service.

Thank you for explaining what the problem was. Now it all makes sense on what was going on, Ebay is always fussing with code and new interfaces but trying to get any information out of reps that know anything is not easy.

I am experiencing this error too in GS 6.9.8 with uploading. When I switched the image server to GS server it did upload the auction but with only one photo. Is there any workaround to this? I know I’m way overdue from upgrading from OS 10.9, so that I can upgrade to GS 7 but it will take some time for me to do that. Any solutions in the meantime would be greatly aprecciated. I have several hundred auctions running. Thanks!

I am surprised that you still can upload items with GarageSale 6 at all.
However, only if you have eBay’s picture service (EPS ) selected, more than 1 image can be upload to eBay’s picture service. Since eBay changed their image upload system recently, you can’t use EPS any longer in GarageSale 6.

Regards, Kristian

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.