Can't use FTP image hosting in new version

Using the same settings as I did in a previous version of GarageSale it will no longer connect to my FTP. I’ve tried every version of FTP (plain, with implicit SSL, and with TSL/SSL) and with and without passive mode. They all give errors, and some crash GarageSale completely. I can connect to my FTP with no trouble using client software such as CyberDuck and other FTP mounting apps, so the FTP still functions properly.

Also, FYI, your help states that Mac Terminal can be used to check FTP settings, but that functionality disappeared on Macs with OS 10.13 High Sierra.

What was the version of GarageSale that still worked for you?

In addition to Ilja’s question:
Could you provide us with a screenshot of the error you get?
Please also let us know which version of macOS you have installed. Is it macOS 10.13 High Sierra? If yes, can you upgrade your macOS?

May we also ask you if you would provide us with your FTP settings - including password? This way we could try to reproduce the issue here. If you are OK with that, please send me or Ilja a private message or contact our support directly. (Don’t post your password/server details here in public!)

Regards, Kristian

Thanks for the fast response. I get different errors for different setting attempted (attached in order of FTP choices)—it’s the same whether passive mode is checked or not, but the second one takes much longer and sometimes crashes GS entirely.

I am on OS 10.13, and upgrading is not currently an option. When and if I do it will only be one version up as I have 32-bit software there is no replacement for, but I can’t risk my workflow any time in the near future.

I will message you with my FTP details so you can try them.

Screen Shot 2021-10-22 at 10.16.05 PM
Screen Shot 2021-10-22 at 10.17.44 PM
Screen Shot 2021-10-22 at 10.17.59 PM

Also, I may have a workaround to try for now. I have uploaded my images to my FTP. I can then populate my listings in GarageSale with those versions directly. Both GarageSale and my image asset management software treat the images normally as if they were local so GarageSale uses them in design with no issues. I’m going to try it on a live listing test tomorrow when I’m less sleepy. My hope would be that if I can get the FTP settings to work later on GarageSale will not care whether the images are already there—in case any listing needs an image or content edit.

Honestly, I have no idea. It was pre-covid but exactly when I’m not sure—I have no concept of time anymore—so maybe 2 years is my best answer. My previous listings are not on Ebay so I can’t check the dates and I upgraded to the newest GS maybe a year ago but didn’t use it until this week, and my TimeMachine backups are newer than my GS install.

Ebay made changes recently and you need the newest version of GS to upload Not one that was new a year ago.

I meant major version, I have the newest version. It is not an ebay issue, ebay doesn’t interact with my FTP.

Did you receive my reply to your private message?

You can always contact the GarageSale support directly via mail, too:

Regards, Kristian

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.