Details in Garage Pay no longer show up

For the last week or so, the “items” window in GP is blank. I do not know what item the customer purchased. I uploaded the most current version without a change. What happened to that vital information?

Is GP compatible with OS Yosemite? I think things started happening after I updated my OS.

Hi, I’m not quite sure what you mean by “items window”. Are you referring to the table below the main transaction table that shows the items that where paid with the selected transaction?

The title of the table is “items”. This entire column has been blank for two weeks fir my incoming transactions. Started all if a sudden and we don’t know which item our customers are paying for nor do we know there address. There us no information on incoming transactions.

Where do your PayPal transaction originate at? Are these eBay payments are there from a custom web store?

I just checked, and at least for current eBay transactions, I still see the purchased products in the items table.

Actually what is going on is that GS no longer downloads transaction from ebay ever since I upgraded my OS to Yosemite. It downloads transactions that I make through paypal, such as buying a Groupon, but nothing from ebay. Is there a token to refresh maybe?

In GarageSale, there is a button to test your PayPal Api Credentials. Did you give that a try.

Yes and that works. I just realized what the problem is. I updated my IMac to Yosemite and now GP is not working with ebay. There are no ebay transactions for either account since Jan 5th. Either GP is not compatible or there is a token that I cannot find to refresh.

Go to GaragePay > Preferences > Accounts. You have to enter your account credentials in this window. Clicking the help button (?) brings up a short guide on how to get your credentials from the your PayPal account page.

Been using GP for years. Credentials have never changed. Only a problem since I upgraded OS.

I am having the same problem. But GP is getting the new totals and new item lists, it is just not displaying them.

I am also on Yosemite but did not have the problem for many weeks after updating.

But I input a buyers name to the search field to get his data.

When I hit delete to remove his name and get the full listing is when the problem jumped up.

I have a screenshot of my windows showing the latest sales and that they do not show in the details window.

I think it would be an easy bug to eliminate but without the ability to see the individual transaction details GP is useless as you have to got to PP to get the info.


Just making sure I understand the issue: once you have used the search field and removed the search field, the transactions table remains blank? Correct?

I upped your user level on this forum, so you can post images now.


Fixing this got set aside because higher priority issues jumped up.

Your summary below is correct. But once I had used the field as detailed in the original text it has never worked again.

Garage pay dutifully logs all the data for every transaction but will never show it, the transactions table is always blank.

In the graphic attached I show that I entered a customer name and the table is blank yet the CSV export window shows the data to export.

If I use a smart folder with all of the months sales, all of the transactions are correctly shown in the export window but none in the main panes.

GP was one of the most useful apps when it worked.

I hope there is a fix.

I think this was fixed back in may with this release:

Can you check and please report back?


Got it down and it did not fix the issue.

GP stil logs all transactions but just does not show anything the transactions table.


If I exported all my transactions (this is thousands of them) would GS be able to read them all back in?

Maybe I could start over with an empty database?

Just need this to get sorted as the lost functionality is a big hassle.



Has any work been done on sorting out this issue?

It seems to me there must be a bug lurking that will get even worse with subsequent system releases (as in more users tripping up the problem).

GP is very much less useful without the data being shown in the tables.


I do not know if that beta fixed it or if perhaps it was never really broken.

But either IWC did a poor job on their GP interface or the default way the windows are supposed to work is flawed.

The problem is shown in the graphic attached.

It is possible to have the window shade rolled all the way up and for the user to not realize that it has happened.

The only clue is the small dot in the center.

Now that I figured this out I remember that this happened one time before but I was working in the window and saw it happen.

So I just pulled the shade down to see the panes.

If you color that thing grey segment a different color it ill be easy for people to realize what happened.


Can’t see a button for the attachment to this post.