GarageSale 7 Crashes When Listing Is Selected


I’ve been using GarageSale 7 through a PC virtual machine for years without any issues (as it’s more convenient to access GS on my desktop system than on my Macbook). Running Mac OSX 10.11 El Capitan.

Just this morning it started crashing when selecting or right clicking any kind of listings, “GarageSale quit unexpectedly.” GS opens up just fine, it only crashes when selecting or right clicking any listings.

By using the forum search option, solutions I’ve tried:

  • Refresh eBay access token

  • Debug options. “Find orphaned listings” “Auto-repair corrupt database” “Rebuild indexes” “Repair hierarchy”

  • Whilst not being able to right click to delete listings, I have been able to delete recent listings I’ve created that my be bad templates imported from GS Scout by dragging the groups into the “Deleted” category then “Edit > Erase Deleted Items”

  • Deleting “WebArchives” folder

  • Checked volume storage & integrity (all is fine)

  • Updated to latest version GarageSale 7.0.21 (859)

  • Re-entered GarageSale 7 Family Upgrade license

I don’t have a recent backup of the database. In really need of some help as cost, purchase date, supplier information are stored in the listing comments below the cost for accounting purposes.

Guessing there might be a bad image or listing template in the database.

Help would be greatly appreciated.

Thank you in advance.

Can you please give this a try? Maybe it helps:

  1. Make sure GarageSale 7 is not running.

  2. Open the ‘Terminal’ utility

  3. Enter the following line and press Return:
    defaults delete com.iwascoding.garagesale7 "GSListingSectionViewController-selectedItemsStorageKeys"

  4. Start GarageSale 7. Does it still crash?

Regards, Kristian

Hi Kristian,

Thank you so much for your prompt reply.

As instructed, opened terminal and copied pasted your command. Tried opening and GS still crashed when selecting any listing, GS starts up just fine, giving the same error “GarageSale quit unexpectedly.”

I have a crash log from the diagnostics folder. Would that be of any help?

Sure, feel free to post it here or send it to the GarageSale support.

For test purposes you could give the new GarageSale 8 a try, too. It can import your existing GarageSale 7 database on first launch.

Regards, Kristian

Sent the crash log to the GarageSale support email.

I have been contemplating upgrading to GarageSale 8, although have concerns before investing in another license key & the time to setup adaptive workflow, since GS 8 does not support MacOS 10.11 which I have other business software that require to run on 10.11.

If I upgrade to GarageSale 8 will I be able to recover/repair my old database?

Thank you again for your help.


After spending the whole day observing the crash behavior, noticed one of the many listings had a category listed as “unknown” accessible without crashing, as it seems categories were not updating since the eBay token was the cause of the problem. Without the steps taken, the token wouldn’t refresh.

Will leave the solution here just in case someone has similar issues down the road with GarageSale…


  • Open GarageSale > Preferences, remove all accounts
  • Close GarageSale
  • Open Key chain access search “garagesale”
  • Delete all associated GarageSale entries
  • Restart Mac OSX
  • Login to eBay, navigate to “Settings > Site Preferences” then revoke GarageSale
  • Open GS, “GarageSale > Preferences” add account back
  • Went to one of the accessible listings had an “Unknown” category that doesn’t crash the software, clicked the category to view window, select the settings/gear/sprocket, update categories

GarageSale no longer crashes & works fine.

If all listings are inaccessible due to crashing, I was able to create a new listing through “File > New > Create New eBay Listing” to access the category update settings window without crashing.

Does GarageSale 8 mitigate issues like this? I’m considering upgrading the whole ecosystem to accommodate GarageSale to prevent issues in the future. Also my database is about 10GB in size.

Thanks again.

GS 8 works way better than 7! Having said that I will tell you I had problems when importing my whole database when I upgraded. It was 180 GB in size though so you should have no problems. If you do, these guys are great and prompt in helping sort out the issues when upgrading and importing.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.