GarageSale 8.4 Beta 5 Released

Dear GarageSale Users,

the fifth beta release (a feature complete version for preview and testing) of the upcoming GarageSale 8.4 is available for you from this address:

We initially had more features planned for the 8.4 version, but eBay is now requiring a different kind of access token (OAuth, which is only supported in GarageSale 8.4) for the product search API.
This is forcing us to release a fixed version quickly to all users. Otherwise our users would remain stuck with a broken feature, something we’d like to avoid.

What’s new in this beta

  • the Listing CSV Import panel remembers what separator character (coma, semicolon) was last used
  • the ‘Copy Listing Link’ in the outline view command works with multiple listings selected

General Notes about GarageSale 8.4

GarageSale 8.4 will be the first GarageSale version that support eBay’s new authorization method (OAuth), which is required to access any of the new APIs that eBay recently released (e.g. getting managed payment status, sending offers to watchers, attaching videos to listings).

Once you refreshed your eBay access token in GarageSale 8.4 from the Accounts section of the Preferences window, GarageSale will be able to ask eBay, if your account has managed payments enabled. If so, it won’t nag you to select a payment method or payment profile anymore.

If you are switching back to GarageSale 8.3.6, after having refreshed your token in GarageSale 8.4, you’ll will need to refresh your token in GS 8.3 once again.

What else is new in GarageSale 8.4

  • fixes “Product Search” feature, which broke through an eBay API change
  • Order section: New context menu entries in the order outline view to change order state (e.g. “shipped”) for selected orders
  • GarageSale will prevent you from starting auction-style listings, when the auto-cancel feature is enabled for such a listing
  • Attributes window: enabled ‘autocompletes’ option for certain attributes (e.g. ‘Artist’ attribute in LP/Records section)
  • Synching: re-worked conflict algorithm to reduce the number of times the Conflict window appears
  • added AppleScript command to manipulate shipping weights
  • various crash fixes
  • text entered in the “user properties” area of the inspector is now searchable
  • new smart group rule for searching “user properties” content
  • GarageSale generates a ‘mobile summary’ from the first 800 characters of your listing description when uploading listings, which does not include GarageSale’s version identifier string
  • the ‘Reveal Original’ command is available from the overview context menu (middle area) in the listing section
  • the number of images used in a listing is shown in Editor mode
  • added new Preferences settings (under eBay > Advanced) that prevents automatic switching to ‘Live’ view when listings are started
  • ‘Condition description’ attribute can be removed from a listing with the Revise command
  • fixed font size issues in Shipping options panel
  • fixed problems with importing specifics from XML files
  • when GarageSale is already running, images dragged onto its Dock icon will get added to active listing
  • fixed a crash when category search returned a single result (e.g when searching for a category id)
  • category panel now displays category id when the category was deleted by eBay
  • category id for deleted categories is shown in Inspector
  • fixed an issue where a click on the “shipped” checkbox in the orders section was not reflected on eBay
  • fixed possible crash when Attributes panel was open when GarageSale was about to quit

This changes allow users to group similar listings using the same user property entry, and use smart groups to keep track of such item groups.

Thanks for using GarageSale,
The GarageSale team

Excellent! Works Great!

Although, now the “Show Listing in Browser” menu command is also enabled when multiple Listings are selected, BUT only One (1) browser window is opened for the last Listing selected. It should open each Listing in a separate browser window. :wink:


I disabled syncing between 8.4 Beta 2 and 8.3.6 installed 8.4 Beta 5 and I was unable to enable syncing. If I close the internal server error, the preferences page goes back to showing Syncing Disabled. I also disabled syncing on my 8.3.6 and tried to re-enable and I got the same problem. I then signed out of GS Pro and signed back in and the problem persisted.

This all started when one of the listings I created on 8.3.6 was not showing up on my 8.4 B2 system; also, I made a change to one of my smart groups on my 8.4 B2 system and it did not show up on my 8.3.6 system so I decided to force a full sync by turning it off and on on my 8.4 B2, when that failed I upgraded to 8.4 B5 and had the same issue (as reported here), that is when I posted here.

BTW I also refreshed my eBay token and updated all listings, tried again. I also closed GS and restarted it and also saw the issue.

1 Like

I have the same syncing issue :frowning: Cannot enable syncing at all…

@elizabetharcher and @Enigmaticca Can you please contact the GarageSale support and provide us with the “Synch Logs”?

These are the required steps:

  1. Open GarageSale 8.
  2. From GarageSale’s Help select “Open Library Folder”
  3. Locate the “SynchLog.txt” file there, compress (zip) it and send it to us. If it’s larger than 10 MB please upload it to DropBox or send it via WeTransfer:

Thank you, Kristian

1 Like

Done, compressed file sent to you at support.

I have Syncing Disabled and this is what my “SynchLog.txt” file shows:

12/15/18, 2:01 PM Synch engine starting up
12/15/18, 2:01 PM setLastSyncSessionIndex: 0
12/15/18, 2:16 PM Synch engine starting up
12/15/18, 2:16 PM setLastSyncSessionIndex: 0

2021-11-21 20:29:58 -0500: Synch engine starting up (GarageSale 8.4b5) on host Neal’s iMac 2021
2021-11-21 20:29:58 -0500: deleting synch token on disk
2021-11-21 20:29:58 -0500: Restarting after state (null) → disabling
2021-11-21 20:29:58 -0500: setLastSyncSessionIndex: 0
2021-11-21 21:52:56 -0500: applicationWillTerminate
2021-11-22 09:19:48 -0500: Synch engine starting up (GarageSale 8.4b5) on host Neal’s iMac 2021
2021-11-22 09:19:48 -0500: deleting synch token on disk
2021-11-22 09:19:48 -0500: Restarting after state (null) → disabling
2021-11-22 09:19:48 -0500: setLastSyncSessionIndex: 0
2021-11-22 09:41:48 -0500: applicationWillTerminate

It logs for every application launch and quit.
This file is 1.1MB in file size.
It does not look like the SynchLog.txt is ever “cleaned out” (created December 15, 2018), nor truncated…


Screen Shot 2021-11-22 at 9.43.22 AM

Not quite similar to Neal I have from this morning:
2021-11-22 06:40:44 -0800: Synch engine starting up (GarageSale 8.4b5) on host MacBook Air
2021-11-22 06:40:44 -0800: deleting synch token on disk
2021-11-22 06:40:44 -0800: Restarting after state (null) → disabling
2021-11-22 06:40:44 -0800: setLastSyncSessionIndex: 0
2021-11-22 06:41:00 -0800: new synch engine state is: Enabled (Disabled → EnableEvent)
2021-11-22 06:41:00 -0800: verifyUserWithEmail:
2021-11-22 06:41:01 -0800: markStorageKeyAsContentDirty: /obj/GSEbayLiveListingsDetails/7DE529CB-6AB8-4932-8652-85C692F5D467
2021-11-22 06:41:01 -0800: markStorageKeyAsContentDirty: /obj/GSEbayLiveListingsDetails/CAF5227E-B81C-4EB3-9737-F1DA6B4C440F
2021-11-22 06:41:01 -0800: markStorageKeyAsContentDirty: /obj/GSEbayLiveListingsDetails/414F6650-28DD-4E06-A047-5F1D0A579F35
2021-11-22 06:41:01 -0800: markStorageKeyAsContentDirty: /obj/GSEbayLiveListingsDetails/E975E0FE-D84F-46D9-9F6D-DA6BD6828A7A
2021-11-22 06:41:01 -0800: markStorageKeyAsContentDirty: /obj/GSEbayLiveListingsDetails/06E38C7A-E06A-4721-8AAE-EB7F640BD8DC
2021-11-22 06:41:01 -0800: markStorageKeyAsContentDirty: /obj/GSEbayLiveListingsDetails/B013CB03-7E68-48B3-AEB6-AFA0D9C63CFD
2021-11-22 06:41:01 -0800: markStorageKeyAsContentDirty: /obj/GSEbayListing/B4417430-8A14-4971-A2CE-4A076D535BB5
2021-11-22 06:41:01 -0800: markStorageKeyAsContentDirty: /obj/GSEbayLiveListingsDetails/1D9FC992-A069-48A5-8A20-704B4D87BDC5
2021-11-22 06:41:01 -0800: markStorageKeyAsContentDirty: /obj/GSEbayLiveListingsDetails/22DA4AA1-7D4F-4D21-A522-437793A60369
2021-11-22 06:41:01 -0800: markStorageKeyAsContentDirty: /obj/GSEbayLiveListingsDetails/54AA4C12-4AD7-48A7-8098-3F2170C63AE9
2021-11-22 06:41:01 -0800: markStorageKeyAsContentDirty: /obj/GSEbayLiveListingsDetails/52BF4768-0603-4E69-BFBD-CB1B422CDED0
2021-11-22 06:41:01 -0800: new synch engine state is: Disabled (Enabled → DisableEvent)
2021-11-22 06:41:01 -0800: setLastSyncSessionIndex: 0
2021-11-22 06:41:01 -0800: enabledStateFailedWithError: Error Domain=com.alamofire.error.serialization.response Code=-1011 “Request failed: internal server error (500)” UserInfo={NSLocalizedDescription=Request failed: internal server error (500), NSErrorFailingURLKey=,{length = 48, bytes = 0x7b226572 726f7222 3a747275 652c2272 … 4572726f 72227d0a }, com.alamofire.serialization.response.error.response=<NSHTTPURLResponse: 0x600001774f80> { URL: } { Status Code: 500, Headers {
“Content-Type” = (
Date = (
“Mon, 22 Nov 2021 14:41:01 GMT”
Server = (
“Strict-Transport-Security” = (
“max-age=31536000; includeSubDomains; preload”
} }}

Dear @elizabetharcher, @Enigmaticca,

can you now try once more? I have found (and hopefully fixed) an issue on our syncing server that may have caused the error.


It works now, thank you

@paul I responded before I saw this issue. I started Sync on my primary (8.3.6) computer and had it overwrite all the data in the cloud. It created a snapshot and then tried to upload it. It got about 75% of the way on the progress bar, and then hung. I gave it about 30 mins to see if it was slow, but no progress. I have sent the synclog.txt file to support and I have attached the graphic picture here.

Hi Kristian. I have already reverted to my previous install of 8.4Beta3 via macOS TimeMachine so I don’t have sync logs. I then also upgraded to 8.5Beta5 without disabling sync and syncing stayed working. I was also getting a regular sync error notice but that has now stopped after I got a popup showing server/local data conflicts for a few of my listings. I presume this is when you fixed the syncing server issue. Anyway, I actioned these conflicts and all is now working again. Thanks!

My sync was active originally between 8.3.5 and 8.4 beta 2 and 5 (I skipped the other betas). What I noticed is that a listing I changed on one Mac did not sync to the other. I used sync now and I finally disabled sync in the preferencest. I found that I could not enable sync again. @paul seemed to fix something, but now the initial sync gets hung up.


there were no more errors on the server. I saw three resets from your account (at 20:47:16, at 20:58:44 and at 21:37:48 CET) but no errors. Maybe this was an issue with your internet connection? How big is your library? Can you try once more?


@paul I’m trying again, I am synchronizing about 250 listings from my 8.3.6 system to my 8.4 B5 system. If it hangs again I’ll post the sync.txt file’s lines from today from my 8.3.6 system.

the problem may be 8.3 to 8.4. there was a big change in the ebay authorizing and you needed to sign in to upgrade your token and if you went back to 8.3 you needed to sign in to get the old token

BTW - I had signed in again and refreshed my token. @paul the sync finally finished – it stalled at about 75% done (according to the progress bar) and set there for about 45 mins, then it progressed fast and said the initial sync was finished. I guess I don’t have a problem, but is it possible to speed it up, as I gave up too early and forced quit GS to terminate as I thought that sync was hung?


we can not really speed the initial sync up as it mainly depends on the size of your database and your (upload) internet speed. But we should definitely have a look at the progress calculation when it simply hangs for that long.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.