GarageSale (App Store Version) not working

I am running the latest App Store version of GarageSale.
For no apparent reason it won’t open. It just says “Loading Data” and nothing happens. My templates do not appear.
I have used GS for a few years now and this has never happened before.
If I uninstall and re-install from the App Store will my data be lost?
Would reinstalling be the best option?
I have a few thousand templates in the database.
Would appreciate some assistance

Am I going to receive any attention to this very critical issue?

Can you open the Console utility (under /Applications/Utilities) and see if there any messages from GarageSale appearing in its window? This could give us a clue what’s going on.

Probably not. But before trying this, make sure you either have a complete backup of your Mac’s hard drive, or at least copy of the GarageSale library folder, which should in your home directory under Library/Containers/com.iwascoding.garagesale .

Probably not, as they may be something wrong with your database which might not be cured by simply reinstalling the application.

Sure, I have been already working on this reply.

Thank you for getting back to me.
I checked the console utility and yes there are messages there from Garagesale and they don’t sound very good -
18/02/2016 10:45:07.935 pm GarageSale[977]: CoreData: error: (11) Fatal error. The database at /Users/Rosemary/Library/Containers/com.iwascoding.garagesale/Data/Library/Application Support/GarageSale/GarageSale.sqlite is corrupted. SQLite error code:11, ‘database disk image is malformed’

Please advise

That doesn’t sound too good. In case you have a recent backup of that folder, I’d try to replace the folder containing the GarageSale.sqlite file from your backup.

If you don’t have a backup, I have to give you “the look” for having “a few thousand templates” in GarageSale, but not having a backup of work. :scream:

Luckily for you we expected situations like these, so GarageSale keeps the past 10 versions of your database file around in a folder called Backups next to your GarageSale.sqlite file. Here’s what I would try to restore GarageSale to a working state:

  1. Make a duplicate of the “GarageSale” folder containing your GarageSale.sqlite file. In case something goes wrong, you can always start again from this point.

  2. From the original “GarageSale” folder delete the files GarageSale.sqlite, GarageSale.sqlite-shm, and GarageSale.sqlite-wal (the last two files might no be present, though).

  3. From the backup folder pick the most recent file. Copy it to the “GarageSale” folder and rename it to GarageSale.sqlite.

  4. Try starting GarageSale again. If it still doesn’t run, try replacing the GarageSale.sqlite file with the next oldest file from the Backups folder.

Hope this helps,

Initially this did not work but after I re-installed the app as well, it worked.
I thank you for your support, however, I am less than impressed by the stability of the application. I doubt I am the only person now actively evaluating alternative providers. GarageSale is cheap but now I realise, you get what you pay for. I would prefer to pay more and not have the headaches. You can take that as a negative criticism but I would hope you would use my comments to improve your product.

Thanks for your feedback. Is this stability issue specific to the problem in discussed in this forum thread, or are you experiencing other stability problems?