GarageSale could not upload picture (502)

I scheduled 10 auctions to list last night. I’ve just discovered that eight of them failed to do so. The message in each case is GarageSale could not upload picture (502). I’ve tried listing them again, same result. I’ve quit GarageSale and tried again, no joy.

I’m using the same template in all 10 cases (the same template I’ve been using without a problem for months now except for a few small text changes), I’ve verified all items before listing. This is really frustrating. I now now two ‘orphaned’ listings on eBay.

FYI I’m using GarageSale 7.0.7 and Mac OS 10.12.3.

I had the same thing last night. The only way I could get my listings to go live was to change the setting back to use eBay’s image service. So the listings went on (late) but the pictures are small and crappy looking.

Hi,

we had some issues with the upload script of our image servers last night. Do you still encounter this issue?

Thanks,
Paul

No. I’ve been able to change the setting back and revise all my listings which don’t currently have bids - that’s half of them - but the ones with bids still look shonky.

Hi,

some of the settings can not be changed after someone bids on the listings. This is a limitation from eBay.

You mean the description? Or the images? Can you post a link and explain more detailed?

Maybe you can revise just the images and the description?

Thanks,
Paul

Once an item has a bid, it’s not possible to edit the text or the images.

Look at this:

http://www.ebay.co.uk/itm/371913274994?ssPageName=STRK:MESELX:IT&_trksid=p3984.m1558.l2649

versus this:

http://www.ebay.co.uk/itm/371913269596?ssPageName=STRK:MESELX:IT&_trksid=p3984.m1558.l2649

I have ended the two auctions that listed last night and relisted them for tonight together with the eight auctions that failed to list. Hopefully all will be back to normal. I will let you know. Thanks for your quick response.

My listings uploaded successfully last night so the problem seems to have been resolved. Thanks for your help.

This is happening to me as I type.
4 auctions uploaded instantly and two refusing to go, just giving me the message:
“WebDAV: Could not dispatch request: Could not send request body: connection was closed by server”

What image server are you using?

Thanks for replying.
I always use the GarageSale Free service, it gives the best results.
After being on here the other day, I reset my preferences and tried again . . . . it worked, all auctions listed.
It is very strange when it happens though, no real reason for one auction to behave differently to another, but there you go.

What version of GarageSale are you using?

Hi
I’m using Version 6.9.8b6 (631)
I know there are newer versions but:

a/ I don’t remember why but the last free update I had caused all sorts of problems, so I went back in time to a version that worked.
b/ I can’t afford to pay for the latest paid for update, especially with no guarantee it will work.

For the record I have a MacBook Air 1.7 Ghz Intel Core i7 running OS Sierra 10.12.3

Very frustrated at the moment, I have just uploaded 3 auctions no problem and another 12 that simply will not work. In fact, I’m really angry.

I don’t have wifi at home and have to make a 60km round trip to do this online stuff.

Tell me why I shouldn’t delete GarageSale right now!!!

I’ve been having lots of problems this last week with the same issue … very very frustrating as I have to try up to 3 or 4 times for the same listing before it uploads … I’m getting two different messages:

Image upload fail - Internal application error, please try again after some time
and
Image Upload fail - GarageSalePictureService: Wrong response ((null))

This is happening on items that I am relisting as well as new ones, never had an issue before … I’m using the GarageSale photo hosting and running 7.0.7. So much time is getting wasted with this issue and I’m pullin my hair out!!!

Hi,

in the old version of GarageSale we used WebDAV for picture uploads, what causes all kind of problems, especially with poor internet connectivity:

Please try the following steps to try out the upload method we decided to use in GarageSale 7:

  1. Open the Terminal application (located inside the Utilities folder)
  2. Enter the following command and press enter:
    defaults write com.iwascoding.garagesale useCGIIwascodingUploadImageAdapter -bool YES
  3. Start GarageSale and try to upload a picture

Thanks,
Paul

Hi,

to me this looks more like an eBay issue. On some days they upgrade the software on their servers (I think its on Thursdays) and then these errors can happen. We can not change anything to workaround this.

Do you use GarageSale 7 or an older release? Please follow the steps in my posting above if you use GS6. If you use GS7, please tell me exactly the time when this happens, then I may find some information in the logs of the image server you are trying to upload to. Also, your IP-address at this moment may help me to find the issue. You can get you (public) IP here:

http://www.whatsmyip.org

Thanks,
Paul

Thanks for your reply, I’ll give it a go next time I have some time on my hands.

Kind Regards
Mike Valentine

www.simplelife.guru

The problem is getting worse and worse everyday … it is taking me 3,4 or 5 attempted to upload a listing due to getting this message all the time (some listings are taking me half an hour to get done!!!)
Image Upload fail - GarageSalePictureService: Wrong response ((null))
I am using the latest version (7.0.7.) and think about it I think that this problem has become an issue since upgrading to this version. I use GS everyday at different times so from 10am to 10pm Australian Time so hard to give you an exact time (having issues right now actually 2.45pm).
My IP address is 110.149.154.231.
Garagesale was working perfectly for me until a month ago and now I am very disappointed with it as it is taking waaaaaayyyyy toooooooo loooooonggg to list anything :frowning: FRUSTRATED!!!

That’s one reason because of I am thinking about using a hosting service for photos, or a NAS… really too long listing, besides lots and lots of listings are not relisted because of some issue with GS image service… it’s too time consuming…

If you are switching hosting services, make sure they offer HTTPs transfers for your images.