GarageSale won't accept photos

iMac OSX 10.10.5, GS 6.9.1
I am new to GS. There is one problem I can’t fix. The drop zone won’t accept photos. When I hold a photo next to the drop zone I see a plus sign but the photo won’t be dropped. I tried ebay’s and GS’s picture service, no change.

Have you tried updating to the latest version of GarageSale? That is 6.9.6 if you purchased it through the Mac App Store, or 6.9.7, if you got it from out website.

I updated to 6.9.6 but still the same. Once I come close to the boundary of the drop box the plus sign disappears and the photo does not drop.

What’s the source of the photos? Finder, iPhoto, Photos or something else?

What design have you selected?

Strange thing happened but I could not replicate it.
I had been using Finder trying to paste the photos. Then I tried from within Photo and that worked. So I rebooted and tried again from Finder. No plus signs visible but this time it worked, too.
Whatever (whoever) the gremlin was, it’s gone and everything seems to be working the way it is supposed to.
Thank you for your help.