GS 8.1 not auto-updating new categories

Happens about once a month when the Category 1 on ALL my listings changes to “Unknown”.

I then have to choose the Category popup from a listing and select the “Update Categories” menu item from the Gear/Sprocket menu. It then updates categories and they all revert/change from “Unknown” back to their normal/correct categories.

So… the Category auto-updating (when there is a revision/change from eBay) is not working correctly… This has been happening for 2-3-4 months???

I’m using: 8.1b20 (1225) on macOS 10.14.6 (18G4032)


Can you please check if your eBay token that is marked as “Default” in the GarageSale preferences > Accounts is up-to-date?
It should be fine if you was able to start a listing with your default account recently.

Thank you for checking, Kristian

Hi Kristian,

How can I tell if my eBay token is “up-to-date”??? See photo below.

Everything worked fine prior to this.

Once I manually updated the categories, then everything works fine again.


Screen Shot 2020-05-11 at 10.51.02 AM

In theory that token should be fine, it’s not that old. Have you been able to start/revise/relist a listing with your default account recently?

Regards, Kristian

Yes, “everything” works great. Quit app. Later that day, or next day, launch app. Try to “start/revise/relist” a listing, and get a STRANGE error! Then I notice the Category is “Unknown”. Do the “Update Categories”, and the category changes from “Unknown” to the correct category and “everything” works great again.

Categories used to “auto-update” when the app started… I THINK they no longer “auto-update”…


I see the same issue frequently.

What error do you get? Is it this one?:
“Keychain Error: There was an error reading your eBay account from your Mac’s Keychain.”

Regards, Kristian

Sorry. Nope, not the Keychain error. Yes, I know I should have taken a screenshot… :slight_smile:

The error is in the Launch Control window when it is doing the Verify.

It is an error regarding a “bad category”, since the category is “Unknown”…

Seems to be a logic error in the “auto-category-updating” code when the eBay category data changes. Only seems to happen when eBay updates their Category data…


This happened to me 1 time after I updated to GS 8 in January. I haven’t seen it since.

This just happened again!

I Quit the GS app earlier today, then this evening (Sunday about 8pm) I re-launched the GS app.

A listing had Sold, so I did a Search for the title, selected the found listing, and clicked the X in the Search field to edit the listing. I do this exact same procedure 20+ times a day…

I then tried to click the "Best Offer + field, and noticed that I could not click it, then I noticed that the Category 1 was set to “Unknown”. Hence, the problem.

So, I clicked the Category 1 “Unknown” popup, and it was “blank”.

I thought I would Verify the Listing…

Screen Shot 2020-05-17 at 8.20.54 PM

This is the Strange Error I get from the Verify…

Then choose the “Update Categories”, which always “fixes” the problem…

Downloading Categories…

Updated Categories downloaded, and correct Category re-selected automatically.
BUT… Options panel drawing not updated, as Category 1 still says “Unknown”.
AND… Bottom of Category popup window drawing not updated as it is still blank.

Select a DIFFERENT listing and re-select this listing and Category 1 shows correct Category.

I THINK the automatic updating of changed Categories is not fully working correctly…

I am in USA. This could certainly depend on what country you are in and when eBay in that country updates the Categories…


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.