GS8 and AppleScript

Where should I put the sample GS scripts folder in Mojave OS to get them to run from within GS8?
They run fine from the Script Editor.

Thanks, Steve

Hi Steve,

from GarageSale’s Help menu select “Show Apple Script Examples”. This should open the folder with all scripts. You can also put your own scipts there.

Does this answer your question?

Regards, Kristian

1 Like

No. I can find the example scripts just fine. I want to run them without using the script editor.

I have other scripts that I have compiled in my users script folder and computer script folder. They are available on the top computer menu bar under the ‘Script’ icon.

I have copied your example script folder to my user script folder. They are now available, but they do not run.

When I select one from the drop down menu below the ‘Script’ icon, that script will not run. Nothing happens.

The GS7 scripts ran fine from my computer script folder.

Is there a bug, or I am doing something wrong? I’m using Mojave OS.


I just tried it here (High Sierra) and put a GarageSale script into the Scripts folder in my User Library.
I then selected it from the script icon in the menubar: It worked like a charm. (I tried it with the “Change Starting bid” script.)

Maybe it’s something that has changed in Mojave?
With GarageSale 7 it still works fine you’re saying?

Regards, Kristian

The script runs, I get a dialog box to enter the bid price, but nothing happens within GS on the listing I’m trying to change.

Run the script thru Script Editor, and the price changes in the GS listing as expected.
Must be something with Mojave.


I know that Mojave needs extra permissions to control apps via AppleScript, but still an app should be able to run an AppleScript on itself. Also, curious why ScriptEditor works, but invocation from GS doesn’t.

I don’t know why, but today I tried running a GS script from the Scripts Menu and it is working.
First thing, the computer asked permission for the Scripts Menu to access GS. I said OK, and now everything behaving normally as it was previously. When it was not working, I never saw the ‘ask for permission’ dialog.

I guess you can close this thread.
Thanks, Steve

1 Like