GS9 library relocation issue via symbolic link on Monterey

On Catalina (10.15) I had created a symbolic link named “com.iwascoding.garagesale9” in “~/Library/Containers/” that linked to a folder named “com.iwascoding.garagesale9” on a different drive to relocate the GS database, which was quickly growing past my Mac’s internal SSD.
This has worked perfectly since.

Now i want to move to another machine with Monterey (12.6), but as i see it, the folder “~/Library/Containers/com.iwascoding.garagesale9” actually appears as “~/Library/Containers/GarageSale” in finder and if i first remove the latter folder, then recreate the symlink “~/Library/Containers/com.iwascoding.garagesale9” with the original target, GS9 won’t even start up or throw an error when attempting to “LOCK” the database.

I’m assuming this is because of the “” file, and probably related to sandboxing.

@ilja - is there a way to restore the original behaviour i established with the symlink?

1 Like

The folder is still called the same, “com.iwascoding.garagesale9". The macOS Finder only shows it as “GarageSale” in order to create maximum confusion for users.

The “Get Info” command will show the actual name.

Yes, i am aware the actual folder name is still the same and macOS gets the “GarageSale” name from the “” file.

However, as i described, i can no longer create a symlink via the “ln -s source link” command to have GS access the library folder on a different drive.

We haven’t changed that code for ages, probably since GS7 first came out. So if the symlink indeed stopped working, it’s probably due to a change in macOS and I doubt we can fix it.

The sounds like GarageSale sees the your database, just has a problem opening it, which suggest that the symlink still kind of works. If GarageSale was unable to follow the symlink at all, it probably would try to set up a new database.

My guess is that either something is wrong with the copy of your library (maybe GS was still open when you copied it), or the filesystem on the drive you copied your library to might not be compatible with the file locking mechanism our database library uses.

If you point your symlink to directory located on your internal SSD just for testing, does that work? Have you checked what kind of filesystem your external drive uses?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.