GS9 System goes to sleep

System goes to sleep even though I have the Prevent system sleep checked.
I have auctions in my scheduler that wont go off unless Im actively using the computer ( MBP 2022 ). As soon as the screen turns off the auctions will stop listing. Happens when its plugged in or not.

Any ideas on why this is happening?

GS prevents my computer from doing anything. No updates, system downloads, nothing. My preference works as it should even when my screen is asleep. Restarts and scheduled listings in the middle of the night works. Is there a system preference setting you have set that may be preempting GS?

I have a scheduler thats set to go off today so Ill give it a go again. If there was anything that would prevent GS from waking the computer I would think its here under battery in system prefs. But since I’m keeping the laptop plugged in, this shouldn’t matter.


GarageSale does not wake the computer up. It prevents the computer from going to sleep automatically. So if you force the computer to sleep (e.g. close the lid) then GarageSale can not wake it up.


Does this include the “sleep” choice in the apple drop down menu?

Yes, there is no way an application can prevent this sleep from happening.

1 Like

I tried the scheduler again today and the first 2 auctions went off but after I walked away the rest of the auctions did not go off. I have the auctions spaced out by 4-minute increments. I’m not shutting my lid or putting the laptop in sleep mode. Its plugged in so its not in low power mode. I’m just walking away. I had no issues with this on my old laptop. I always had the GS scheduler go off on Sunday and I wouldn’t touch my laptop for days before that. The scheduler would still always go off.

Maybe the warning messages you get are blocking the upload.
If you start one of the listings manually do you get the same message then? If so you could let GarageSale suppress the message in future by right-clicking on it and selecting “Ignore Future Warnings”.

Regards, Kristian

The warning message is because GS doesn’t have payment checkbox for Ebay managed payments. For now, I did as you suggested and right clicked on the warning and selected ignore future warnings. I have auctions scheduled to go off at noon today and I’m heading out before then. I will check when I get back. Thanks for the info, hopefully thats what it is.

Here is a screen shot of my GS prefs.


And just to do a quick follow up… I started the same schedule at 5:52pm… The first auction went off so i walked away and came back 12 minutes later and the first auction was the only one to go off. Now, in the past on my old computer if something like this were to happen, GS would have a pop up that would let me know that auctions did not run and I could check boxes and start them. thats not happening either.

Im happy I found the problem but Im not too happy with the reason behind it.

Its the requirement to enter a password if the screen saver comes on. My old laptop had no issues with this feature being on. This offers no security.

Is there any solution for this security issue? I would like the security of having to enter a password to get into my laptop after I walk away from it and the screen saver comes on and have auctions run in the background.

We have the “Require Password immediately” setting on our development and testing machines, but we cannot reproduce the problem.

Maybe it has to do with the type of Mac?

and GS 9.0.5

That’s strange. The same macOS version and almost the same MacBook I just tested this on. I’ll sent you instructions on how the helps us debug this further in a private message.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.