Help adding videos to GS

Hi, I posted about this issue a few weeks ago and paused working on it.
I’ve had no luck importing videos through garage sale. Someone suggested I use Imovie and add an image which I tried, when adding the video GS immediately prompts me to add a title, when I do I clock OK and the same prompt comes up, it will keep asking me to to add a title, but when I add a description and click upload video the app crashes. This happens every time. Am I doing something wrong or is the app just not capable of adding videos? The file I’m using is super a small mp4 : 4.4MB
dimensions are 1280x720 … the image I’m using is also small 648x792 pixels.
Could really use help here


I would like to add that I read the article about adding videos:
I’m pretty sure I’m hitting all the requirements

the resolution is 720p

I just tried it here: I selected a video and in that panel I also entered a Title and Description. After hitting “Upload video” the upload process started as expected.

Could you post a screenshot where exactly you are trying to enter a title so we can see what you see?
Taking screenshots is done easily:
Press Command-Shift-4 on your keyboard simultaneously, then select an area with the cursor. It will be saved as an image file on your desktop.

It also might be that there is an issue with your video file. Does it play properly in QuickTime Player?

Hi, thanks for the response, yes it works fine in quicktime player:
Here are some screenshots, the first is the crash window, the second is the last step before the program crashes, the third is the “get info” screen for the video file, the last is the screen before i bounce the video from iMovie and the last one … including the last two in the next message
Screenshot 2024-05-09 at 4.41.04 AM

here are the other two screen shots

Hi, Just following up here.

At first glance the video format looks fine to me.
Can you sen us the crash report, please? (paste it into a Text Edit file)

It also might be helpful if you could send us some system logs. Here’s what to do:

• Open the “Console” application (from the Utilities folder inside your Applications folder).

• Depending on your macOS system you might have to click on “Start streaming”.

• Try to start GarageSale and to reproduce the issue. This will should print some output to the Console. You might want to click on “Stop” to stop logging at this point.

• Copy the GarageSale logs. You can use the search field in the toolbar of the Console window to filter for relevant messages by entering “GarageSale”.

• Open the “TextEdit” application and paste in the copied logs into a new plain text document.

• Save the text document and attach and post it here so we can investigate further.

Hi, I responded via email with the requested info. Unable to upload an RTF here.
Please let me know if you are able to see it.


Thanks for getting back.
Attached is the crash report and console record.
Hope this helps.

(Attachment Garage Sale Console report .rtf is missing)

(Attachment Garage Sale Crash Report.rtf is missing)

Here they are as PDFs, this should work. Thanks.

Garage Sale Crash Report.pdf (109.0 KB)
Garage Sale Console report .pdf (98.7 KB)

Got a message the attachments were rejected.
Here they are as PDFs

Garage Sale Console report .pdf (98.7 KB)

Garage Sale Crash Report.pdf (109 KB)


sorry, these crash logs do not help. But can you try to reproduce this with the current test release here:

This will send a crash report to our new system and it may help a bit more.


Hi, just reproduced the crash.
Attaching the crash report here.
Also sent it to apple
Hope this helps
Crash Replication.pdf (113.1 KB)


did you reproduced it with the Alpha version as I asked you to do? As these reports does not help to understand the issue and are not able to reproduce the crash here.


Hi, Yes the version you sent to me. 9.8a5 (1664) I reproduced the crash. again and attached is the console record. Is there is different way you would like the report to be sent?

Does is send to you automatically? Please let me know if there’s anything more i can do to help.


Crash Replication Console.pdf (74.2 KB)

Hi, Yes the version you sent to me. 9.8a5 (1664) I reproduced the crash. again and attached is the console record. Is there is different way you would like the report to be sent?
Does is send to you automatically?


Crash Replication Console.pdf (74.2 KB)


from the logs I can only guess what the issue is. But at least it seems to be unrelated to the video import/upload. Can you please make sure that your account(s) are all up to date? Can you please try to refresh the token(s) and trade to reproduce this issue?


Thanks, That was the issue, the program was not linked to my ebay account. Doh! Sorry about that. My first time using the program.
Should I go forward using this alpha version you had me download?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.