Help in restoring data needed

HI There

Had a hard drive failure and was unable to do a full restore from backup because of the size of the replacement disk.

I restored the application folder and the container file system ok and GS will start but says the database is corrupt.

I appear to have changed the user name on restore and I think it is now a permission problem. Can you help?


Can I just import the listings from a backup?

Hi David,

I am sorry to hear. I assume you’re using GarageSale 7? If so, did you follow the “How do I transfer my GarageSale 7 database to another Mac?” instructions from the FAQs (point 16)?

It should be no problem to trasnfer & open your GarageSale database from the backup on your new system, that’s why I am asking.
What database error did you get exactly?

No, you can’t transfer single listings - only the whole database.

Regards, Kristian

Hi Kristian

In the past O=i have just moved in the container directory as per your instruction in FAQ16. As this did not work I used Migration Assistant to replace the whole application and Container from my backup.

Still the same issue. I have tried a number of different backups but I get the same message.

It should work. What exactly happened if you tried it as described in the FAQs? Did you get the same “database is corrupt” message?

Regards, Kristian

Even tried a backup from Mar 2017 but the same message.


Hi David,

can you please give this a try? Maybe it helps, maybe not.

  1. Make sure GarageSale is not running.

  2. Open the ‘Terminal’ utility

  3. Enter the following line and press Return:
    defaults write com.iwascoding.garagesale7 autoRepairCorruptDatabase -bool YES

  4. Start GarageSale 7 and wait a bit.

Does it help?
If so, quit GS7 and enter this in Terminal to disable the repair mode again:
defaults write com.iwascoding.garagesale7 autoRepairCorruptDatabase -bool NO

Regards, Kristian

1 Like

All fixed Kristian

The message was a bit of a red herring. I left GS running over night, regardless of the message, and all 12,000 records have been returned.

I think in the past we have recognised that there is some dorm of corruption in the database and that is probably what GS could see but it was able to get past it.

Thanks David

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.