IAF Token Invalid

I haven’t done an auction for a long time – only buy it now items. But I decided to do one. I had about 10 items that were already listed which I ended in order to include them in the auction. Then I had about 60 new listings for auction. I set up the scheduler and left, so the computer was sleeping when it was time to start. All the ones which had previously been listed started fine. All the new ones did not start due to the token thing. So I checked my settings and renewed my token. Then I set the scheduler to start in 1 minute, so the computer was not sleeping, and I left the house. I came back, none of them had started – all invalid token. So now I am doing them 1 by 1 without the scheduler, which works fine. Please fix the scheduler. This cost me money…

Is there anybody who will help? Kristian? Anyone?

What version are you running?

Ventura 13.1 and GS 9.2.1

And you refreshed your token already?

Yes I refreshed it. And that isn’t it. I can upload one by one and it works fine. It’s only the scheduler…

Back in sept 22 someone else had the same issue but a new version fixed it then. I do a few scheduled and they went fine for me. It may be the 60 in a batch. Have you tried a smaller group?

Years ago I used to do auctions of 1000+ items and this would work fine.

The odd part about the 60 I just tried to do was that there were about 10 which I had already listed as Buy It Now through GS. I ended those listings in order to put them into the auction. And those 10 uploaded just fine with the scheduler…

It may be the verification process is broke. The 10 went ok maybe because they already were verified.? GS guys will have to help you with this.

Yeah hopefully they will respond! Thanks for trying though…

Unfortunately, I am bit clueless here.

  1. You created these 60 listings from scratch, did I get this correctly?

  2. Do you have store categories and/or business profiles selected?

  3. After refreshing the eBay token, did you use the “Update Account Details”, too?

  4. Does it maybe help to delete your eBay account from the GarageSale preferences > Accounts, restart GarageSale and then re-add it?

  5. Does it maybe help to add an interval of a few minutes in the scheduler event settings?

  1. Created about 60 from scratch, and then 10 others which I had previously created as Buy It Now. I used GS to end those 10 others. Then, using the same templates, I changed them to be auctions and grouped them with the 60. The scheduler started those 10 just fine.
  2. I do not use store categories or a business profile.
  3. I did not update account details. Next time I can try that.
  4. Also I can try this next time if it persists.
  5. Going by the fact that the scheduler started the 10 recycled listings 1-minute apart, it seems illogical that this has any effect…? In fact, #2, #3, and #4 also seem illogical in light of the fact that the scheduler started the 10 without a problem…

I had asked about this about half a year ago and just wanted to add that I am still encountering this issue. I have never had scheduled listings work consistently since upgrading to GS9. When I was using GS7, scheduled listings worked flawlessly.

Once I refresh my eBay token, scheduled listings may work once, but after that I always get the “IAF token supplied is invalid” error. For what it’s worth, this occurred before and after using business profiles and across three different computers.

I saw your question when I searched for an answer to this. I also saw that it went unanswered. Maybe if we keep this alive, something will be done…

Kristian I’m happy to share the screen and/or give you whatever info you need so that we can get this fixed. I would like to run another auction sometime soon…

I’m running an auction today, 1 min apart, but I’m using the computer at the same time and it is working. It must have something to do with when the computer is sleeping…

Hm, the GarageSale scheduler can only start a listing when the computer is NOT in sleep mode.

Bildschirm­foto 2023-02-17 um 08.33.37

In the GarageSale preferences > eBay > Advanced there is an option for it: “Prevent system from sleep while scheduling listings”

I already had that box checked in the GS settings! And of course the computer was on and GS was running… So probably checking that box isn’t actually keeping the computer from sleeping.

What do you have on the general IOS preferences? This is what I have and listings start when the screen is asleep but not disks.

Just to make sure we are looking at the right code paths: Do you have a subscription for GarageSale Pro? Our own Macs are mostly opted-in into GarageSale Pro, so maybe we have to sign out that bug.

Also, could you restart GarageSale with the Control key held down and enable remote logging with this identifier:

Next time you see the error, please not the time (and your time zone) and get back to us, so we can check if there’s something in your logs.