Image upload failed could not connect to server

I am trying to start auctions and am getting the image upload failed, could not upload picture to garage sales picture service could not connect to server. I have the pro package. I was able to list last week. I have over 2000 listing on right now. thanks

Worked for 2 minutes and then got the image upload failed message again.

Still getting the upload failed message.

I too am getting the message “Image Upload Failed - Could not upload picture to GarageSale’s picture service. An SSL error has occurred and a secure connection to the server cannot be made”

Has the server’s security certificate lapsed ?

It lists a few and then stops if the security certificate lapsed would it list at all? And where do see if it lapsed?

I was able to start 15 listings without changing anything, so I think it is on your end. And every other website works, I have printed postage from eBay’s site all morning.

We are not sure what is causing the problem at the moment, but we are working to find a solution ASAP.

1 Like


I am getting 100% failure to upload the the GarageSale Image server due to the SSL error. This has nothing to do with ebay or ebay’s servers, just the GarageSale image server.

Me too. I tried to upload a few new listings on Sunday evening, and they also failed due to the GS Image Server issue. Hopefully all will be up and running soon!


there is not issue with the certificate of the server here (we did not change any thing and are using LetÄs Encrypt certificates for multiple years now).

Can you open the following URL in a browser? Can you click on the small lock icon next to the URL in the browser (Safari) and which certificate do you see? It should be valid until November 28th, 2020.

Which version of GarageSale and macOS version do you use? There might be a root certificate missing if you can not open the image-url in a browser.


I just clicked on the lock icon and it said this certificate is valid for both of the links Catalina 10.15.6 is the macOS version. This just started on Sunday 10/20/2020. I was able to start 61 listings on 10/12/20. and a few today.

Which version of GarageSale do you use?

8.1.1 I am using pro version


I had a fast look through the logs on the servers and did not find any issues. However, I just rebooted both of them, can you try the upload once more?


HI Paul, it worked will let you know if I get that message again. You might want to ask a few of the other people who were having the same problem. Thanks


20.20pm 21-09-20 - Seems to be working OK now.

The images in the links open fine with a secure padlock icon and note. OSX 10.13.6 Firefox 80.0.1 (64 bit)

Safari show the expected certificate date.

GarageSale now working as expected 8.20PM 21-09-20

I’ve just managed (22/9/20 at 08.45) managed to upload 9 out of 10 new listings - the last one failed due to Image Upload Failure - Could Not Connect to The Server.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.