Missing PayPal address


#1

All my listings are being blocked from uploading by a “Missing PayPal address” alert. I see a bunch of people were getting this message in Oct. & Nov. I followed instructions that apparently solved the problem for some people then, but it hasn’t worked for me. In GS preferences, I deleted my eBay user details and shut GS down; then deleted my eBay token from the Keychain access utility on my Mac; then opened GS and added a new eBay account with my regular signin info. However, all listings are still blocked.

But it didn’t solve the problem. Now in the Keychain access I don’t see any eBay token. There is an 'application password" line there for iwascoding.garagesale7.HockeySDK from the Nov. 11 date I upgraded to GS7.

I’ve refreshed my GS token with eBay twice, and also re-entered my email address in the PayPal GS preferences pane. I don’t see anything in the MyEbay account page that seems to be a problem.

I’m using the latest GS version 7.0.13 and Mac OS 10.13.3.

Thanks for your assistance.


#2

Can you post a screenshot of that alert so we can see if it’s coming from eBay or from GarageSale itself?


#3

Here’s a screenshot of the alert. Also, shots of the GS Preferences panels, showing the PayPal email address is correct; and that the eBay Access Token has been refreshed since this alert began blocking me. Thanks!


#4

This error message indeed comes from within GarageSale. Seems it is now picking up the address you entered in the Preferences window. When you quit and restart GarageSale, are the PayPal address fields in the Preferences panel still filled in?


#5

Yes, they are.

I shut GS down and reopened it several times previously, and now just did that again, with no change. The PayPal address space is always filled in with the proper address. I’ve also erased the address a couple times and re-entered it, again with no positive results.

Yesterday I also went into my TimeMachine backup, to see if restoring the GS database to an earlier state when it was working fine might cure things. I hoped this might disable the error alert which started blocking every listing upload since Friday, but even after this, the GS alert still continues to be displayed. For every one of a few thousand listings stored in the software, the exclamation mark alarm appears in the Options section of the Inspector panel to the right of where it says ‘Payments: PayPal’. Here’s a screenshot of that section for one listing, and it is the same with everyone of them:


#6

(It looks like only the top half of that screenshot (of what a typical Options panel of mine now shows) may have come through, so here’s the bottom half of it, where the error alert exclamation appears:


#7

Thanks for your reply. I answered it in your GarageSale forum before noticing I could answer you by direct mail.

–Nick


#8

Dear Ilja,

Please don’t worry about my problem or work on it for the next 24 hours. Last night, a different program seemed to have developed some kind of connection problem, and it’s possible they could share the same cause. After I get together all the notes I’ve scrawled on about a dozen pieces of paper concerning these issues, I’ll call AppleCare late this afternoon. The GS problem may be unrelated to this new quirk, but maybe Apple can help solve it if something more general is wrong with my Mac that is causing a similar bug across both pieces of software.

At least that’s my hope! I’ll let you know if their assistance cures the big glitch I’ve had with GS since Friday, or if GS is still broken for me, and we’ll need to keep working on a solution. – Best, Nick


#9

Too late. :wink:

If you find the time, please download and run this special build. When you see the PayPal error, can you check for output from GarageSale in the Console application (under /Application/Utilities)?

http://downloads.iwascoding.com/downloads/GarageSale_7_2018-03-13.dmg

Thanks.


#10

My apologies for causing you to waste some of your time. The problem I’ve been encountering apparently wasn’t caused by any bug in GS.

Instead, it seems to have arisen from something dumb. I got a new iMac last month, and set it up with the Magic Keyboard that accompanied it. However, I much preferred my old extended USB keyboard. So last week I hooked that up to the Mac, and since everything worked fine initially, I didn’t give the changed setup another thought. I didn’t try using GS the first couple days after that, so when I did on Friday and GS was totally blocked by the error alert (but with none of its settings any different than usual), I didn’t associate the problem with the keyboard change.

However, when attaching my old USB keyboard to the new Mac, I merely moved the bluetooth magic keyboard a few feet off to the side. I’m not used to having one which has a little on/off switch, though, and neglected to turn off its power when I put it aside. But it appears that somehow the signal it continued to give out was breaking the connection between GS and PayPal. Now, after turning it off, and refreshing my eBay token, all the error alerts disappeared, and I was just able to smoothly list an item, as a test.

So, it looks like I’m back in business, after four nights of fitful sleep. The cause of all my frustration was a very simple and stupid thing. Computers are so complex, though, that a simple thing can mess them up in a big way.

It is a set of circumstances your other customers are unlikely to ever reproduce, but in case someone else has a connection problem like this in the future, make a note in your knowledge database that it could be caused by a conflict when two keyboards are active at the same time on their computer.

Arrgh! (Enjoy the rest of your day.) - Best wishes, Nick


#11

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.