Photos not uploading to eBay gallery if I revise pictures on auctions

For the past 6-8 months I’ve been having trouble with pictures showing in the eBay gallery ONLY when I revise the template by changing/adding pictures. It never happens when I upload a new auction. I’ve been going into eBay deleting all the pictures and uploading them all new there in order to get it fixed.

Please help–it’s a pain!



Kerry, I’m a fellow user. Maybe tech help will be here soon.

Do you use Verify Template before you start your first listing from a new template? I sometimes get one of a couple different error messages regarding my photos. One is a URL error and the other is a size error. I delete the photos from the template and drag in a new batch of jpgs in a group from Finder. That usually clears up the problem.

If you edit in Ebay, all your effort will be lost next time you try to use the template. Fix the problems in the GS template, then use Revise Running Auctions to make the changes.

good luck

Thanks, are you saying that if I ‘verify’ the template that then if I need to go back and revise the pictures that it will upload them properly?

I realize that it is stupid to have to go into eBay to make revisions, but haven’t seen a way around it. It happens ONLY on revision, not on first uploading the auction.

I’m trying to help you clarify the problem so the tech guys can help you. I’m learning too but I thought it could be helpful if you tried the verifying process.

What sort of message do you see for your templates when you test them with “Verify Template”?

Did you create the templates in GS or were they imported from Ebay?

What version of GS and Mac are you running? They will want to know.

… and yes, replacing the photos in the template , then "Revise Running Actions’, solved the problem for me.

Ok, thank you Robin.

I create all templates in GS. OS 10.10.3, GS 6.8.

Even if I verify a template, which I just did, then add a new picture, NONE of my pictures show up–all pictures are gone when the revision is completed. The only way for me to then revise an auction’s pictures is to go into eBay, which is time consuming.

This is a newer problem for me with GS, never happened before 6-8 months ago.


Hi Kerry,

please update to GarageSale 6.9.5.
Version 6.8 is too old for OS X 10.10.

Please download GarageSale 6.9.5 from the GarageSale website:

Regards, Kristian

Thank you, Kristian. I just downloaded that version. BUT,

each time I looked at updating GS before it said that I was using the most recent version. How come?


Hi Kristian,

For the most part updating it helped, but it still does happen that that my pictures are not uploading and I have to go into eBay and upload them there. Again, this only happens when I am revising an item, even if I am not touching the pictures.

Please can you help?

Thank you,


HELP please Kristian,

Please read my thread. This problem is continuing.


I think your best solution is, after you have revised your template and are ready to resubmit it to eBay, delete all of the images across the top of the template and add them all back. I know this is a bother, but I am confident that if you do this, all of your pictures will show up on eBay. When you do this, my theory is that you are re-establishing the connections to the pictures. A little more work, an additional step, but no longer any frustration.


Where are you uploading your images to? eBay’s picture service or your own servers? We will try to replicate your problem here this week.

Unfortunately eBay test system for developer (aka "sandbox) doesn’t support gallery images very well, which makes problems like this hard to diagnose.

I am also having the same problem. I tried to revise an item in GarageSale and Ebay sent a message stating that I had lost the GALLERY PHOTOS. I have also tried to delete them in the GarageSale template and drag in a new batch but it does not work. All the photos for that auction has been affected now and I can’t revise in Ebay or GarageSale. Ant suggestions would be helpful. I just purchased GarageSale last week so I REALLY want it to work out.

What have you selected in GarageSale’s Preferences > Image Server as image upload location?

I know this is an old thread but I appear to have the same problem after just revising two auctions. The images are hosted on GarageSale’s server and they appear in the main template on eBay but not in the top of the page with all the eBay information.

I am using GS 6.9.7 and I did verify the template before uploading again. The only changes I made were to slightly lower the prices and remove the options to auto accept or reject best offers. The pictures were already online and all working perfectly when uploaded originally so it seems strange they are now missing. Any ideas?

This is annoying I’ve tried adding the images again but nothing has changed and now eBay is sending emails saying that buyers cannot see images.

EDIT: Now it won’t even let me revise the auctions. Garage Sale is seriously playing up today.

2ND Edit: I managed to update the images so they show properly now but only by revising the auctions directly inside eBay. I had to delete the images and upload them again using the eBay uploader.

Thanks, we’ll into this again. We contacted eBay API support a while back, but unfortunately that didn’t help.

I would have tried hosting the images myself but my server does not allow uploads using Garage Sale FTP for some reason. It shows the test image but will not allow others.

It might be useful if it was possible to upload images to our own server with an FTP client like Yummy and simply add direct links to the images inside Garage Sale. If there are problems with the API though none of this may be that helpful.

You can add URL images. Switch to the edit modus and select “Add URL Image…” in the menu that pops up when you click on the ±button below the images.

That’s good to know! Thank you :grin:

I’ll try uploading in future using my own FTP client and see if that is more reliable.

You can also send me your FTP credentials (in a private message) and I will try to fix the issue with your FTP server. There are plenty of different FTP servers out there, but GarageSale should support a bunch of them.