Problems found: Missing PayPal address

Once again, every one of my listings has a red exclamation mark graphic next to the PayPal fields.

And once again, I have to try to remember what to do when this happens.

The error message says the PayPal address is missing. But it isn’t. I went to GS → Preferences and could see it. But I removed it and put it back in just for good measure. Nothing.

I hit the “eBay Access Token” as well as the “Account Details: Update Account Details” in Preferences.

Then I went to click on the sprocket and can’t find it.

Please tell me where the sprocket is and what else I need to do to hundreds of my listings.

I wonder what sprocket you’re referring to?

At first, please give this a try: Click on the PayPal field in the GarageSale preferences > Accounts, press Command-A followed by the Delete key and re-enter the data.

What you also should check is if you have selected a payment profile in the payment options. If you have, it might be that the profile uses out-dated PayPal settings.

You’re using GarageSale 7.0.9?

Regards, Kristian

i have the same problem
I tried to reenter the paypal address in the account preferences but without success.
I do not have any payment or other profiles.
If I remove the payment option with paypal I can not put ads online, the buttons can not be selected.
Thank you for your help
Im using garage sale 7.0.9 version


which system version do you use?


i use garage sale 7.0.9 version
mac book pro sierra version 10.13

I am sorry you still have trouble.
Can you please give this another try?:

  1. Open the GarageSale preferences > Accounts.
  2. Remove your eBay account by hitting the minus button at the bottom.
  3. Restart GarageSale 7.
  4. Re-add your eBay account in the GarageSale preferences > Accounts.

If this still won’t help can you please check your account settings on the “My eBay” website and make sure that your PayPal account is connected with your eBay account there?

Glad to hear that did the trick.

macOS High Sierra
Version 10.13

Thank you. This did he trick.

But I still don’t know where the sprocket – or THING THAT LOOKS LIKE A GEAR – is.

What exactly are you trying to do? Updating the category data manually?

Regards, Kristian

I am having the same issue … but the solution here has not helped.

This started today so now I cannot list any items. The only thing different is that I upgraded to 7.0.9 on Mac High Sierra 10.13 …

I have checked PayPal and Ebay credentials all OK.

So, removing and re-adding the eBay token in the GarageSale preferences > Accounts did not solve the issue for you, did I get this correctly?

Regards, Kristian

Hi Kristian
I tried everything I could think of including re-adding Ebay token but in the end what worked was I added my Ebay account again in the settings (so had two accounts listed, one as default) then deleted the default account. This seemed to force a re-sync and it worked.