Scheduler not launching auctions


#21

Paul

I haven’t run it all the way through to listing but the countdown timer is frozen as soon as scheduler is minimised to the Dock, even though GS is still open. I bring it back up and there is a short pause till it corrects itself.

I’m not technical enough to do any “tweaking” or other stuff as you outline. There is an energy saver utility on the Mac that I have set as shown below (i disabled the Power nap trying to fix this issue - I have never found the App Nap function Ilja referred to earlier)

Richard


#22

Hi,

as I am a bit clueless here, it may help to see what exactly happened on your machine. Can you please make a small screen cast (QuickTime Player > New Screen Cast) which shows what’s happening on your side?

Please make sure the Console with the system.log is open and then minimise GarageSale into the dock.

Thanks,
Paul


#23

Screen

I have a screencast but its 217MB so way too big to email - how do I get it to you?

There is an enabled Scheduler event that shows 23:21 to next event that I minimise at a screen clock time of 20:43. When I restore the Scheduler from the dock the time to next event is still 23:21, then there is a burst of log timer activity and the countdown drops abruptly to 23:17.

GS is open and minimised when this happens.

I had a half way pleasant surprise today when I left GS open and GS Scheduler open (not minimised) overnight last night. Although the Mac screen shut down due to inactivity when I went back the Scheduler countdown clock was correct, so problem is only when application /scheduler are minimised.

Richard


#24

Please use the upload link on this page to send us your video. Thanks!


#25

I think I managed to get it uploaded
Richard


#26

Thanks for the video!

We found the issue that prevented the “Next Launch” banner from immediately updating when maximised from dock.

We also changed some more settings for the upload timer, so maybe this version works for you. Can you please give it a try and report back:

http://downloads.iwascoding.com/downloads/GarageSale_7_2018-02-05.dmg


#27

This version makes a difference to the lag between when the system becomes active and uploading starting BUT

The key problem is that a if either
A) the scheduler is minimised to the dock or
B) the screensaver cuts in
then scheduled uploads will not happen until somebody presses a key or moves a mouse.

This is still a rank failure if, for example, I want to go away for the weekend but program listings to start in my absence


#28

Sorry to hear that this still doesn’t work for you. Can you please check if you you are still seeing the messages in the Console utility when you have minimised the window with this version:

http://downloads.iwascoding.com/downloads/GarageSale_7_2018-02-13_1.dmg


#29

Even Curiouser!

When I have GS and GS scheduler activated with this version, there is no system log activity, (see picture attached) but the countdown clock on the scheduler is working.


#30

Not sure why you don’t see the logs anymore, but that the countdown keeps getting updated sounds like good news. The countdown timer and the schedule are both driven by similar timers, so hopefully we finally fixed this issue.


#31

Really not fixed at all to be honest. So far we seem to have made the recovery from sleep/minimise mode a bit quicker but not solved the issue of why the timer is not keeping going when minimised or when the rest of the systems are inactive

The problem remains

  1. that when GS Scheduler is open, but minimised in the dock, the GS Scheduler countdown timer freezes
  2. When the GS Scheduler is open, and not minimised, but the Mac system goes to sleep through inactivity, the GS Scheduler countdown timer freezes.

At the moment the only work-around I think I may have found is that I have to disable all sleep functions on the Mac, and then leave GS Scheduler open on-screen. That gets me through being away for a weekend, but its a faff around if anybody else needs to use there family PC when I’m scheduling listings


#32

Hi,

this should never happen as GarageSale is using a system call to prevent the sleep. So in my opinion there is something really messy with your system.

Can you try to create a new system account, launch and setup GarageSale there and look whether it still behaves so strange?

Thanks,
Paul


#33

Paul

I set up a Test user from a clean base and put the supplied version of garage sale (GarageSale_7_2018-02-13_1.dmg) into it. I set a dummy listing into the scheduler and watched what happened.

On the Console there was no record of “Schedule Timer Fired” on the system log. (As with my main setup)
Listings would not launch from a dock minimised scheduler (as with my main setup)

However, I then found an update to GS version 7.0.13b2 and found that this would launch listings from a dock minimised scheduler; so have now downloaded that version on my main user base, and have now tested that satisfactorily - at least when launching from a dock minimised scheduler. I haven’t yet found the courage to try it from sleep mode!

I don’t know what you did but the new version appears to have rectified at least part of the problem

Cheers

richard

but updated to


#34

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.