Smart Group Title Does NOT Contain - SOLUTION!

Well… Today I discovered a new feature that will solve the issue that Smart Group triggers do not have a “Does NOT Contain” operator.

Thanks to the Feature Request to be able to sort the popup menu alphabetically, yesterday when I tried out this feature with the <option> key held down the Smart Group window opened and the “+” buttons changed to “…” buttons… Hhhmmm…

So… I clicked the “…” button and it appeared to add a “group” of “nested” operators (All, Any, None).

Well… Now I can do all sorts of fancy operations if I can combine All (And), Any (Or), and None operators in one Smart Group!!!


Today I tried this out and sure enough it works great!!

I also discovered that you can click-hold-and-drag on a trigger line item to rearrange trigger items.

The simplest Smart Group would be “All”, Title contains “abc”, <option-key>click “…” button to add “None”, Title contains “xyz”. Which is actually Title contains abc AND DOES NOT CONTAIN xyz.

Below are photos of 3 Smart Groups that I now use.

  1. A search for: title begins with “Spectrum” AND title contains “engine” AND (title does not contain “dcc” AND title does not contain “diesel” AND title does not contain “steam”)

This is very useful to “exclude” items from a Smart Group that returns a large number of items!

The next 2 are more complex examples. I’ll leave the full interpretation as an exercise for the reader. :slight_smile:

  1. Check for the existence of All 3 textblocks in each Description.

  2. Make sure all (well most all) expensive listings have the Best Offer flag set, except for certain listings.

Now, if there was just a “is not empty/blank” trigger for text fields, then I could test for empty or non-empty text fields also!


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.