Synced file on one computer is corrupt

I have been using sync for a few days with no issues. Yesterday it seems like the data file on my iMac has become corrupt. I listed an item on my iMac and as soon as it listed GS crashed. The listing disappeared from the folder but It shows up in the search results. When I try to move it the move command does not work. When I try to delete it, it causes GS to crash. The listing synced properly to my MacBook and I’m able to move it there with no issues. I’m deducing that the file on the server and my Macbook are fine, just the file on the iMac is corrupt. How can I delete the data on the iMac and re-download the entire file from the server or do you have another solution? I have over 1400 listings.


I also go between an IMac and a Macbook Pro (both older, but on OS X 10.13, and I have yet to go a few days without syncing breaking - The first time it happened, the listings became corrupted on my laptop (My imac is my primary computer.) I had to turn off syncing on both devices, delete the entire database on my laptop, turn syncing back on and re-upload the database from the iMac and then turn on syncing on the laptop again to download the data to the laptop. Again, it worked for a couple days then became corrupted again. I had no choice but to turn off syncing completely. Because I frequently make minor changes to my listings and ‘revise’ them, I can’t afford to not have syncing working perfectly. I have about 900 listings at the moment.

1 Like

Can you please contact the GarageSale support directly? It might be needed that you send us some log files.

Regards, Kristian

I tried emailing twice directly to the link provided but the emails are returned undeliverable. Perhaps if you would send a message to my email address on file then I can respond.


Hi. What logs can I send you.

Bob Werthman

Please try our support email again:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.