Unable to load images into a template

Hello, I am using the latest version of GarageSale on an iMac running Sierra (kind of an older iMac). I just installed GarageSale and was going to train my worker how to list items.

We are using an iPhone to take the photos and then send them through iMessage to the iMac.

The images are then either saved to a folder on the Mac, or they are dragged directly onto the drop zone in the new listing.

When we do that, often nothing happens. The screen seems to refresh but no photo. Other times, one of the photos will show, however it shows up twice in the preview.

The default image will often show up as empty.

To test, we tried to start the listing, but it would error out stating there was a problem with the image uploads.

I also noticed after repeatedly doing this several times on one listing, when I tried to list the item, it stated that I have too many images on the listing. I found that selecting delete all images, would clear the “invisible” images but trying to drag and drop the images would result in the same problem.

This is the second computer I have seen this happen, but I cannot seem to narrow down the issue. My guess is it has something to do with taking photos on an iPhone and then sending them over iMessages, then to GarageSale, but I cannot be certain.

Has anyone experienced this before? I love GarageSale but if I cannot use photos then it’s useless :frowning:

Hi tokki3,

what you describe might have to do with a known issue with drag & drop from Apple applications, e.g. Photos.app to so-called web-views (like GarageSale’s Previe mode). My guess is that iMessages is affected, too.

However, dropping your photos in GarageSale’s Editor mode should work fine.

The good news is that drag & drop photos from Photos.app (and probably iMessages also) to Preview mode should work again in the upcoming version 8 of GarageSale.
With this version you’ll also be able to take photos with your iPhone directly from within GarageSale by using macOS’ “Continuity Camera” feature (requires macOS 10.14 or newer).

Hope this helps,

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.