URGENT! Garage Sale won't stay open!

Since last week my copy of GarageSale crashes within seconds of opening. As it was the holidays I wasn’t concerned but now I am back to work and it’s unusable. It started suddenly with the same version I had been using for a while (7.0.5 Beta 2) so I downloaded the new update but the same thing is happening.

It crashes, I hit REOPEN, it crashes again. I have updated my OS and rebooted but still crashing.

Do you have Time Machine or a very recent back-up? I had that happen and something got contaminated in my library/containers/iwascoding folder.

Thank you for the reply!

Yes, I do. How do you fix it?


Replace both the garage sale app and the iwascoding folder in the container folder. If they are of the same date and time (same backup) restart and everything should work. At least it did for me.
Go only as far back as just before the problem started. If you have auctions on eBay that aren’t there you can import from eBay.

Forgive me for sounding dumb but I can’t find the containers folder.

It is in your “Library” folder. So your home user folder, then Library, then Containers. Hope that works for you!

Yes but it is hidden, open terminal, paste

defaults write com.apple.finder AppleShowAllFiles YES

Then press enter key, then

killall Finder

Again enter key, now user>yourname>library>containers…

After doing what you need, open again terminal:

defaults write com.apple.finder AppleShowAllFiles NO

enter key

killall Finder

again enter key, now folders are hidden again. Don’t know if there is a faster way, I always do so…

There is a very quick way to reveal the library: When you are in Finder, click the “Go” button at the top left of the screen. Then click and HOLD the option key on your keyboard, which will reveal the hidden Library in the Go menu.

If you are still seeing the crashes, please let me know what e-mail you are entering in the crash report panel, so I can lookup your issue in our crash database.

Okay, I did that (took 12 hours to import the file, over 100,000 items in it) but it still won’t stay open! :sob:

It doesn’t stay open long enough for the crash report panel to come up. I get the Apple one though.

Did you try to uninstall, install again and replace the new folder in containers with one from a backup before it started happening?


It just started spontaneously. I was able to still work with it for a few days (albeit frustratingly) then it wouldn’t stay open at all.

I mean not before it started but now, did you try to erase all and restart from zero using a folder from a back-up before the problem appeared? Not using time machine but just downloading again GS, installing and then sostitute manually the folder (obviously “empty”) with one from a back-up… but this is just a suggest…

Okay, no, thank you for the suggestion. I just tried opening GS as an empty file and it is stuck on Generating Preview

Try to uninstall and then install again from zero the latest version…

(to be honest I don’t know if there is an uninstaller for GS, if not, use something like app cleaner to delete all related files… but make sure you have at least one back-up!!! I did it some months ago when it continued crashing and then I had no more troubles, just preview stuck sometime, but I restart and then it seems to be fine…)

After re-opening the empty one it has started downloading categories. Should I try getting it to open my file?

Uhm @hevydevy I have a doubt… did you touch the folder in containers while GS was open?

No, I moved it before opening the new one

Ok. Well, in my opinion 100.000 is like a punch… if you have another mac export a little number of listing, import and see if it works, then if it does CLOSE GS (make sure GS is close!!!), go in containers and manually paste a com.iwascoding folder copied from a backup before the problem started… then click on “sostitute” (still while GS is closed) and wait that the folder is completely copied. After this, open GS and cross fingers… I did so and then I had no more crashes (I mean not so often…), I hope this will work also for you…