Attributes are not saved

Every time that I put the item attributes and exit they are automatically deleted

Schermata 2021-12-11 alle 10.35.48

Thanks for letting us know.

Could you please make a small video, for instance with the “New Screen Recording” command in Apple’s “QuickTime Player”, that shows the steps you are doing that result in lost attributes? This way it’s far easier for us to reproduce the bug.

Also, I’m assuming you are using GarageSale 8.4?

i used garagesale 8,4

Thanks for your video. We have a hard time reproducing the bug here. Nevertheless, we made a few changes that might cure the problem. Can you please give this version a try and let us know if the bug is still there:

ok! thx .
I try and I will let you know

1 Like

the problem is always there

Could you please try with this version once again:

If you are still getting the bug, can you do another video.

Ok well, I’ll test this version and give you some feedback

1 Like

if you need other material please tell me

Thanks for the video.

I think the bug is that you get a “torn-off” attributes window (recognizable by the close button) when you open it for the second time. This should happen and is probably the root cause for the lost attributes.

But I have still no idea why this is happening. Will keep on digging through the code… :hot_face:


This OCCASIONALLY happens to me also, can not figure out what “triggers” it… Does not happen very often…


1 Like

I have created an experimental version for you, which should crash as soon as a “torn off” popover appears on the screen. After you get GarageSale to crash, please launch this version another time, so it can upload a crash log to our server.

This way we might be able to figure out, why you get a “torn off” popover window sometimes.

Also, do you perhaps have any macOS extensions installed to change something about windows or drag behavior?

Thank you!

I am using the magnet extension. If you think it might conflict I can try disabling it and testing GS

I didn’t understand. I need to reinstall the version 8.4.1b3 or do I have to install a version that you will give me?

Sorry, I forgot to post the link. Just use this version until you got the crash, and then only do a second run to get the crash log uploaded. Afterwards you can never to beta 3.

Meanwhile I will have a look at this Magnet extension. Maybe it has a way to opt-out from GarageSale.

ok! after the test which version should I use to continue working?

After the test, please revert to 8.4.1b3 posted in this thread, as the constant crashes in Beta 4 might make GarageSale hard to work with.

so. I have tried several times to cause the problem but now everything seems to be working fine. I decided to use it normally to create a listing but GS hangs on other steps. the old problem does not seem to appear now

Thanks for giving it a try. Maybe it’s a timing issue, that depends on how quick eBay responds to GarageSale requests or what GarageSale might have already locally cached.

I tried version B3 and now the old problem is back. What do you think I try the latest beta or continue to use the B3