GarageBuy 3.2 search results not working


#1

Hi,

With great pleasure I have been using GarageBuy for several months, until recently the search results stopped working correctly.

I have re-authorized my account and that all works correct. I can see active and won bids etc. just fine. But any search I do ends up in an eternal spinning search GIF. As can be seen in the attached screenshot.

I have used the “trick” to set the ebay certificates to always be trusted as mentioned in this topic: GaragePay stopped connecting - to no avail.

My system is Mavericks 10.9.5

Hopefully someone has an idea what this could be?


#2

I echo pnut. I’m not getting any Search results working on OSX 10.9.5. Are you working on a fix or is there a workaround? Thanks.


#3

Here is guide that might fix the problem:

Please let us know if that works for you.


#4

Hi Ilja, thanks for your response. I followed the procedure for Fixing Certificates in Keychain Access as given on the web page to which you directed me. However, there are no Certificates on my System which have the Blue + (cross) as suggested.


#5

I got ebay certificates in my keychain, tried the lowendmac.com fix, to no avail, still no search results.


#6

Can you give this version a try and report back:

http://downloads.iwascoding.com/downloads/GarageBuy_3.2.1.dmg


#7

Unfortunately a no-go


#8

Sorry, seems I forgot to take care of a certain server in the version posted yesterday. I fixed this and uploaded a new version to the same link. Before downloading again, please delete the version you downloaded yesterday to avoid confusion:

http://downloads.iwascoding.com/downloads/GarageBuy_3.2.1.dmg.


#9

Hi,

unfortunately since I updated last night to 10.10.3 I’m experiencing the same problem. I cannot also refresh the token because when I open the window to do it is empty. Any hints for me?

Thanks


#10

Try following the instructions given in this post: http://www.iwascoding.com/2015/04/10/fixing-garagesale-after-recent-os-x-security-updates/ and repeat them for the URLs https://api.ebay.com, https://svcs.ebay.com, and https://open.api.ebay.com.

Hope this helps.


#11

it worked!! Many Thanks ilja!


#12

I would have sworn I had already done what the article said, but you have added a urls there - https://svcs.ebay.com - , that is not mentioned in the article… now it’s working again!

Thanks for the fix!

P.S. https://open.api.ebay.com - no response on that url


#13

The article was just for GarageSale. We didn’t know that GarageBuy was also affected at the time of writing, so the other servers are missing there.