"IAF token supplied is invalid" Error for Scheduled Listings

I upgraded to GS9 the other day and all has been going well except for the ability to start scheduled listings. None of my scheduled listings start. They all receive an “IAF token supplied is invalid” error.

Does anyone know what the issue is and how to resolve this?

iaf

Did you already try to refresh your eBay access tokens in the GarageSale preferences > Accounts?

Regards, Kristian

That seemed to have worked! I didn’t think I would need to refresh the access token since it was last refreshed a few days ago when I upgraded. Thanks!

This issue started occurring again for me. If I am actively using my Mac, the scheduled listings start successfully. However, if my mac is in Sleep mode, the scheduled listings return the “IAF token supplied is invalid” error and do not start. In GS7, the listings would start fine in sleep mode.

Is there a new setting or something else I should configure to resolve this? Thanks.

See other thread "GS Scheduler does not upload listings unless "screen is left on" on iMac. They are working on a debug.

Thanks for referring me to that thread! But I am still thinking my particular issue is a little different. I attempted the workaround of not requiring the password when in sleep mode–as referenced in the linked threads–and my listings still did not start. I am receiving an “IAF token supplied is invalid” error which I have not seen other users say they have received.

It’s strange that refreshing the eBay access token doesn’t fix this eBay error.

However, I found an old thread in the eBay discussion board. This worked for someone who had a similar issue:

• Go to “My eBay” on the eBay website.
• Find the “Site Preferences” there. Then find “Third Party Authorizations”.
• GarageSale should be listed there. Try to remove it from there. There might be an option like “Revoke this authorization”.
• Next, restart GarageSale and fetch/refresh your eBay access token.
• Afterwards check if it re-appears in “Third Party Authorizations” on the eBay website.
• Try the GarageSale scheduler once again.

I can’t promise anything but maybe this works for you as well. Please let me know if that solves the issue for you.

Regards, Kristian

I followed the instructions. I had two GarageSale tokens–probably from GS7 and GS9–and removed both of them. Now I no longer get the IAF token error, but the listings still do not start. The listings just show the error icon without any explanation as to why they did not start.

gserrir

• Are there any error signs if you select one of the listing in question in GarageSale’s main window?

• If you hit the “Start” button in the toolbar, do any errors appear in the Launch Control window?

The only warnings that show up are the standard ones related to Best Offer / Immediate Payment and Managed Payments. If you would like me to try anything else, just let me know what I can do.

Do these warnings maybe block the scheduler starts?

Try to trigger them in Launch Control, then right-click on them and select “Ignore future warnings like this”. Maybe this already does the trick.

I was able to get rid of those payment warning notifications, but the listings still do not start. They just display the error sign without any further information. The listings start fine when started manually.

To make things slightly more complicated, GS9 Pro is being used with the same eBay account on two computers. Yesterday I tried a scheduled listing on my partners mac and it started fine while the OS was at the lock screen. However, on every additional attempt for scheduled listings, the other mac returns the IAF Token error.

Any other ideas on what to try here? Is there a way to find out why the listings are not starting since there is no reason specified in the scheduler?

There is a pretty good chance, that this version solves your issue:

https://downloads.iwascoding.com/downloads/GarageSale_9.1a14.dmg

Thanks! The scheduled listings are starting just fine now.

1 Like

After a few days of testing with the ALPHA version, I’m still running into trouble. The first batch of scheduled listings start fine, but every batch after that returns the IAF token error and the listings do not start. I need to delete the third party authorization from eBay and refresh the access token for scheduled listings to work again.