Missing Account Token on Listing

Been updating listings today to reflect the TSR requirements of offering free returns. Out of the blue, one item will not let me revise the listing. On the verify screen it is stating:

Missing account token

GarageSale can not process listing, because there’s no account token.

We only have one account set up within GS 7. Refreshing the eBay token did not help. This does not appear to have happened with any of the other listings so dar.

I’ve looked around but haven’t seen a way to correct this random error. Any clue?



that’s really odd. Can you please double-check whether you have selected the correct store category?

If you switch to “Live” mode or open the running listing on the eBay website in your browser, it it listed under the correct eBay account?

Regards, Kristian

Everything with the listing looks fine within Live mode in GS7 and online at eBay. It is when we try to revise the listing that GS Launch Control goes wonky about it.

I am a bit clueless, unfortunately.
Are you really sure you don’t get the same error when you try to revise another listing? If so it might be a general issue with your token/keychain.

Regards, Kristian

Maybe it’s a problem with GarageSale accessing the Keychain, or Keychain iCloud sync that’s doing something weird in the background? Did restarting your Mac perhaps solve the problem?

Rebooting the iMac and GS7 and the problem persists. It is just with this one listing. We’ve revised hundreds right before and right after with no other issues.

How many eBay accounts do you have authorised in GarageSale?

I read that you check Live mode looks OK for this listing, but have you double-checked that the right eBay account name is shown in the live inspector?

We only have one account authorized in GS and use it for all listings.

I don’t see a way to assign a seller account to a listing. Am I missing it somewhere?

Have you tried if the re-linking from the “Import from My eBay” panel works to re-add the account?

See this post to learn how it works:

I also have the same problem. I first experienced it a few months ago and had to create new listings to fix it. i now have 3 with that problem. If I copy the listing, I can list and change the new one. I think that the listings became corrupted when I was trying to update them manually while an update all listings was running in the background

I have found a couple of other listings that I was not updating when the Update routine was running.

Did you already give Ilja’s advice a try? Maybe it helps:

There’s a way to “link” a listing in GarageSale with an active listing from eBay.

To do this invoke the “Import from eBay” command. Don’t import any listing there, just drag the desired listing from the “Import from eBay” panel to the arrow icon next to the Item Number field in the Live inspector to link listings in GarageSale with listings on eBay.

This animation shows how to do it:

Regards, Kristian

Hi Kristian,

I have not tried it yet. I am wondering what to do with the listing in GS. I don’t want to have two GS listings for one eBay listing. Right?

If I end the problem GS listing, it will end the eBay listing and I will not have anything to pull into the new listing. Can I do as Ilja suggests and then simply delete the problem one even though it shows as active?

It is odd because, I can relist the problem item, but I cannot revise it.

Thank you,

Carlos Lacerda

You won’t end up with two listings. You just “re-link” the listing.
Please have another look at my previous post. It’s worth to give it a try.

Regards, Kristian

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.