Disappeared listings sometimes... reappear

did you remember when we discussed about disappearing listings some months ago Disappearing listings and Disappearing listing 2 ?
Well, I am finally (happy day!!) going through my listings one by one and checking the archive if everything is there and ok… well, as we discussed and as I imagined, everything is not there and not ok because there are many listings that seem to be disappeared, which mean should exist but are nowhere in GS (anyway I hope/think this problem is no more here). However, I found something very strange during this work. Sometimes, when I digit the univocal code in the search field and GS find the listing, it is marked as NEW (so not expired!). I select it in the left hand side bar, I click the X of search field and… disappeared! That listing is not selected. Did you get what I mean? So, I digit again the code, find the listing, I double it (while it is displayed), press X and now the new one (the copy) is correctly displayed where it should be (like the original one is there, but not visible). The original one is still missing, I don’t know where it is (it does not exists but exists if I search for it… crazy…). The orphaned function does not work (honestly I guess never worked, at least for me). So… @ilja, since you have my postcard listings in your database (I don’t know if your/my files are recent or not), please could you digit CAIB9 and see if it happens also to you?? VIDEO
Please reply me something :pray:

Thank you

P.S. I have to say some further things. First, this happens only with a very little number of “lost listings” since those disappeared generally does not show in search at all. Besides, I noticed that those disappeared and/or existing-non-existing are most of the time consecutive (like 4 or 5 listings originally listed one after the other). I think it might be important…

Yes! I found one of those yesterday. In the search but didn’t actually exist. Exactly as you did, I ended up duplicating it while in search and re-starting it that way. Interestingly, the duplicate ended up at the bottom of the list, just on top of the “Lost and Found” rather than its alphabetical position.

This “solution” is fine for recovering the lost item but only once you know its lost.

I am still finding many missing items but not as many as before. I think it may be related to crashes (and no, the initial Lost and Found search found some but none since). I was good with crashing for a couple of months then recently it started again.

And, yes, of the ones that were recovered in the Lost and Found were also consecutive, or made from the same template.


PS. While not as serious, the random re-setting quantity to ‘0’ is driving me crazy. I went through last week and batch changed every listing to have a quantity of ‘1’ but now they are randomly back to ‘0’ again.

Hello Tracy! How are you?
So we are still having the same issues after so many time!!! I just don’t understand, are only we so unlucky or is there anyone else in the universe who can confirm it??

The same for me! The doubled one is at the bottom of the list in that folder.

For me, it found 2 listings, from that time I tried it sometime and never found others while there are actually some “orphan” listings somewhere.

I found a probable solution to this!! This bug must come from a beta version very very old because (at least for me) it happens only for very very old listings (I mean created many months ago, although in the meanwhile they have been relisted many times). So the solution is: disabling the quantity field! I mean, if there is only one quantity in your stock, there is no reason to keep the quantity field marked and set to “1”. So, unmark and might not be set to “0” quantity after relisting. If you have more quantity in your archive… just forget to use multiple auction, if you do relistings. When I sold one and have one (or more) other identical items, I put it again for sale manually.
I hope this will work also for you.


@ilja what is the reason of your silence??

Looks like a bug in the algorithm that selects a listings when leaving search mode to me. Will investigate later…

@ilja so could you find those “disappeared” listings inside my database? If so, I am looking forward to hearing from you!!

Sorry, I only have a subset of your listings imported, and not your current, complete database. A search for CAIB9 yields no results.

Can you please upload these files from your GaragSale Library folder to Dropbox as .zip archive and sent me the link once done, so I can try to replicate the behaviour?

  • GarageSale.leveldb
  • GarageSale-FTSIndex.leveldb


@ilja , do I have to send you these files, the database or export the “disappeared” listings (if possible)? I did not understand what you exactly need…

The two files I listed are the necessary components of your database to replicate the bug.

I don’t need the other parts like images for this one.

@ilja I sent you a message

Thanks. Downloading your file right now. Will look at it tomorrow.

Thank you so much!!

Have a nice evening

Please give this version a try and run the “Repair Hierarchy” command once:


For me that made both items I found while searching for CAIB9 appear in the regular hierarchy.

@ilja I did not find that command, so I pressed ctrl+alt while opening and then select “rebuilt indexes”. Now it is 5 minutes it is only spinning ball, I am a bit worried… did I click the correct command?

@ilja 10 minutes and again spinning ball!!!

Panic, it’s almost half an hour everything is stuck so with spinning ball and fans that run, in activity monitor it says GS does not respond, I am close to force quit but I am really worried it can damage the database. Don’t know what to do…

49 minutes of pure panic!!! I will never repeat something like that and… nothing changed! CAIB9 still is there but disappear if I try to select. So, or I wrong the command

or it does not work. @ilja please, if I wrong the command, tell me that carefully :disappointed_relieved:

And please, can you explain here or in your manual what do those command do? For example, I “rebuilt indexes”… what does it mean? Might it compromise my listings? What change?? After spending weeks going thought thousands listings one by one you will understand my worries…

Sorry, “Find Orphaned Listings” would have been the correct checkbox to click.

@ilja and what about this?

[quote=“fedege96, post:17, topic:3596”]
can you explain here or in your manual what do those command do? For example, I “rebuilt indexes”… what does it mean? Might it compromise my listings? What changed in my database?? [/quote]

The “Rebuild indexes” option is very time-consuming, but not harmful. It just rebuilds the indexes for speeding up database lookups from scratch, in case they have gotten out-of-sync with the actual data: