Follow-up: Searching for Order by Title

Continuing the discussion from Searching for Order by Title:

Just following up on this, I am still having this issue even with latest beta.

the search will find older orders from 2022 and before, but leaves out current orders when searching by title (from within orders). if i search by buyer for example, it finds the correct order.

Yes, I agree.

Searching Orders by Title does not show any recent results.

Searching Orders by Buyer Name works correctly.


This will be fixed with GS 9.4 Beta 12, but you would need to rebuild your index for the fix to work for existing orders. To do so, please start GS with the the control key down and choose ‘Rebuild indexes’.

Not working for me yet. I confirmed I’m running the new beta 12. Closed and reopened with rebuild index, but still doesn’t find recent orders. Tried rebuilding process twice. Also shutdown and restarted macbook.

strangely, orders received in the last few days (since I installed beta 12) work (titles can be searched), and much older orders work, there is just now a hole between very old and very new orders.

There was a bug in GarageSale that caused new orders not to be correctly indexed.

So, when first adde “title search for orders”, all existing order title’s were correctly indexed, but new orders weren’t. Beta 12 fixed this, but the orders you received between the feature rollout and beta 12 are not.

To fix this, you need to manually update your index:

  1. Quit GarageSale
  2. Restart GarageSale while pressing the control key on your keyboard
  3. Hit the “Rebuild index” checkbox

thank you for the reply but I’ve tried the rebuild index a few times and it seems to go through the process but it doesn’t change the order search results. As a workaround, I search in listings and get to the order from there.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.