GS 9: again problems with eBay token

to continue this thread: GS 9: problem with eBay token

I finally updated all my machines to GS 9 beta14 . Two Macs have Monterey, 1 still has High Sierra because it cannot be updated to newer macOS. All Macs are running ONLY GS beta 14. Now I expected the issue with the eBay token was fixed… but it isn’t!! The M1 Mac mini still gives me the problem, while other 2 Macs works fine. There must be something wrong with that computer. Token still breaks after some hours (the same behavior as I already explained in the other thread). I am totally stuck on my work! I wanted to start with auto cancellation soon, but if token expires in a few hours, I cannot work at all. @ilja @Paul what’s going on?? @kristian I already tried several time to follow your instruction deleting account and also in the keychain, but it didn’t work. Let me know any data you need, I will send you everything possible to fix this issue.

Thank you

i find myself wondering if it could be a syncing issue that is compounded by the different OS?

This is what I thought too at first, but now I am not sure. How is it possible that only one Mac has this issue? And why the token works again if you quit and reopen GS, without refreshing it? Maybe I am wrong, but now I think it has something to do with leaving always on that Mac. GS is up and running 24/7, maybe this breaks the token somehow (?). This is really giving me many troubles because I can’t work on…

I have a single mac running GS 9.0b14 24/7 that hasn’t been shut down and restarted since March 22. I have had no token issues

Thanks for reporting, are you using Monterey?

Do you have iCloud Keychain Synching enabled on your Macs?

yes, I am using 12.2.1 on a late 2015 iMac

Hi Ilja,
no, there is no syncing in the Mac mini. I didn’t set ID apple and no iCloud account is set. The Mac is only for GS and teamviewer to work on it from my MacBook Pro and from my phone.

Can you share a screenshot of the account preferences? What is the state of the account while the token does not work?

Just to make sure: you do not use GarageSale 8 on any of these machines, right?

I do not have any other Mac with GS 8 working, I am only using GS 9 beta 14.

The situation in preferences is exactly as before. Here is another video just recorded: Dropbox - Token - Simplify your life

  1. open GS > preferences shows token DOWNLOAD date > GS does not work

  2. Quit GS

  3. Reopen GS > preferences shows token EXPIRE date > GS works

Can you try to find out what do you did immediately before the token fails? So we may find out which may cause this.

Actually I do absolutely nothing ! Computer is always on, I set “automatic listing and orders update” every 5 minutes, it works but there is absolutely nothing else. I just leave the Mac on, there are no cancellations or restarts active yet, nothing nothing. So I really don’t know what’s going on…


does work all the time? But just not the command you execute manually in the video?

By the way: maybe you can start GarageSale in English when you make screencasts/shots as this makes it much easier for me to understand…

So here is what I found out:

The label of the token date states “Token Download Date:”. This is only the case if an old token is saved in the keychain, that only (older) versions of GS8 are capable of writing (we think so far but we may be wrong).

If you have a newer token (that was downloaded/refreshed using GS9), the text should state “Token Expiration Date:” (“Data di scadenza chiave accesso:”).

So this tells me that either GarageSale or anything else is overwriting the Keychain entry with an old entry and/or token.

We build a special version of GarageSale that should crash whenever GarageSale itself tries to write or overwrite this entry. Can you please have a try:


Hi @paul ,
here I am, sorry for delay but I could not check before.
So… I have really bad news for you. Now also my second Mac is giving the same trouble ! Until I worked with GS 8, everything worked fine at least in my MacBook Pro, now both Macs are giving troubles with token. The third Mac is only working for creating listings, so I don’t know if token is valid or not there. I only know that until I updated my Macbook pro to Monterey and GS to 9, I have the same issue with token. It is just less usual to happen because I do not leave MacBook Pro always on. It just happen when I leave it on in my office, when I switch it off the token returns to be valid, it will then broke in some hours if I leave it running.

Apart this, concerning your questions:

The Mac mini is always on, it never shut down. GS is open and set in preferences to “update every 5 minutes”. I do not invoke listing updating manually.

How can I change the language?

Yes, I see.

I am going to download it right now. The Mac is always on, so it will probably crash later this night.

Let me know for anything else I can do. Thanks to you for your work.

Kind regards

@Paul until now GS seems to be still on and never crashed, but the token issue is always there. What’s wrong?

That’s odd. We specifically modified that B18 to crash when it attempts to write an invalid token to the key chain.

Here is one other you could try. Got to Keychain Access, select your “GarageSale eBay Account” entry, hit “Get Info” for the Entry, go to the “Access Control” tab and remove all items from that list, except “Keychain Access” itself.

When you use GarageSale 9 next time, it should ask you to grant Keychain Access once again.

If you see your token go bad once again, please check how many instances of GarageSale are now on the “Access Control” list for your token in Keychain Access.

I just did, but when I go to the “Access Control” tab, this is what I find:

It says “impossible to modify access for this item”. So I cannot delete it anyway. Is this normal?

It looks the same for me, after I deleted my existing account/token from the Keychain and GarageSale and created a new account from scratch.

We changed to access permissions, so when we ship major updates of GarageSale, users don’t have to go through these “Allow Keychain Access” panels. That’s why you cannot remove/delete individual apps anymore. I forgot about this. My apologies for making you go down that rabbit holes.

Still, we cannot figure out why parts of your token disappear from the keychain.