GS 9: problem with eBay token

I am having some problems with eBay access token in GS 9 beta 14 on MacOS 11.0.1 (I just realize it needs to be uodated, I will see if it happens again on the latest macOS).
It seems GS does not save correctly the token. This is the third time I enter my token (and it works) saying it will expire on 25th September 2023 at 22:24 (is it normal that every time the date is always the same??)

Anyway, this morning again there was no expire. Strangely, it said the token was updated today at 17:34 (but “today” was at 10:22 :thinking: ). I had to enter again because when I tried to upload a listing, the red warning said there was no valid token. After refreshing the token, everything worked. Let’s see when it happens again.

If you still have issues with the eBay access token, it might be required to renew the eBay token completely:
Remove your eBay account from the GarageSale preferences > Accounts, restart your Mac and then re-add your eBay account.

If this won’t help, please give this a try:

  1. Quit GarageSale if running.
  2. Open the macOS “Keychain Access” application and enter “GarageSale eBay Account” in the search field. (If you don’t find anything try it with “ebay token”.)
  3. Right-click on the eBay account token in the Keychain and select “Delete”.
  4. If done, restart your Mac, start GarageSale and add/refresh your eBay access tokens in the GarageSale preferences > Accounts.

Regards, Kristian

Hi Kristian,
thanks for your help.
I just deleted account and restarted my Mac. Then, when I clicked on the + icon to add a new account, I noticed that the ebay page still had my account selected and didn’t ask to put the username, is this normal?

I will check if this works (this morning the token was expired again). If not, I will try the second solution and then let you know.

Thank you

You are looking at a cookie that Ebay has on your computer that tells ebay who your computer is and NOT GS telling Ebay your ebay user name.

Ok thanks.

@kristian unfortunately it didn’t work. GS lost again the token. I will try the second solution and let you know.

@kristian nothing to do, also with the second solution the token problem persist. It still lost the access. What’s going on?

Mine also needs to be refreshed like every day or two.

I am using GS beta 14 on macOS 12.3 . Might this help? And yes, I also have to refresh token every day, also two or more times daily …


actually, the token should not behave differently on GS8 and GS9. About a year ago eBay did migrate to a new token system that actually has a refresh and a access token. The date in the preferences reflects the refresh token, which should be valid about a year or so.

The refresh token is only used to refresh (hence the name) to get a access token wich is only valid for about 15 minutes. This token is then used to connect to various eBay APIs.

As said before, also GS8 did use the new token, but if you have a (very old, deprecated) token it might never expire and this might be the reason why still be able to use GS8. If you update the token in GS8 you will then get the pair of new tokens. The new APIs from eBay do not support the old, deprecated tokens at all.

So the main question is why you get a refresh token that lasts only a few hours. How do you know that your token is expired? Do you get an error? Which error do you get?


In addition it also would be helpful if you (fedege96) could enable “remote logging” for GarageSale on your Mac. This way we can see the communication between eBay and GarageSale.

Here is what you need to do:

  1. Start GarageSale and immediately click and hold down the ctrl-key on your keyboard.

  2. A small window should appear allowing you to enable “debug options”.

  3. In the Debug options panel, check the “Remote Logging” checkbox and paste this unique identifier: STy9Pg

  4. Try to trigger the eBay error/reproduce the issue and also refresh your eBay access token

  5. Restart GarageSale. If you still see a “Logging” menu in GarageSale menu bar, click on it and select “disable logging”.

  6. Please let us know when you’re done with this.

Regards, Kristian

Hi Paul,
I know because when I try to list or revise any listing, the red warning appears (like now… again!): it says “Gs cannot elaborate the listing because no access key is present”:

Schermata 2022-03-29 alle 13.09.04

If you go to preference, the access token seems valid BUT something is different: it says when the token was downloaded, not when it will expire as it said when I updated the token:

Schermata 2022-03-29 alle 13.10.41

Incredibly, I just quit GS and restart with debug enabled as Kristian explained and… surprise! Now the token works! I mean, 2 minutes ago it didn’t work, I quit GS, reopened with debug and the token is working. BUT… something changed again in preferences, now the token expire date is back (27th September) and there is no more the download date as in the last photo:

Schermata 2022-03-29 alle 13.19.36

I didn’t do anything with the token, just closed the app. How could be possible? Might this bug depend if you leave GS always opened?

Now the debug session is closed, I will check if it happens again. Then I will try to quit the app, reopen (without debugging) and see if it works or not. If not, I will do another debug session.

@paul I should have been able to find the reason of the bug. If you don’t quite GS for some time, the token somehow broken. As soon as quit the app and reopen, the token works again. Please check video (don’t pay attention to strange color, I am working remotely on GS within teamviewer).

Did you perhaps re-authorize GarageSale 8.x on that Mac recently?

No I didn’t, that computer is brand new. Only GS 9 is installed.

The problem persists. I just checked and the token was again invalid. Now in preferences a warning appeared under my account nickname: “upgrade necessary”

Please let me know what I can send you to catch this issue. This is a big problem for me because I cannot work this way.

This screenshot says your account “needs upgrade”, right? This is only visible if your account does not have a new token. Do you use an older GarageSale version in parallel? Do you either sync the files or the keychain manually (e.g. by a link to a cloud service)?

I can not think of a way GarageSale 9 should write the keychain data in an older format. This can only be done by an older GarageSale version.

Yes, exactly, but it makes no sense. The token has been updated some hours before.

Yes! I have still GS 8.4.1 on my older Mac, but it should use the new ebay token, doesn’t it?

No I don’t. What do you mean by synching files?

See that 8 and 9 have different application identifiers. This might be confusing your computers

So can’t I use in parallel version 8 and 9? This might be a problem. They are not in sync, I just use 9 to manage listings and the 8 to manage orders…

Of cause you can. But as we have several customers who do this there is something special about your setup. My guess is that the old version is writing something into the Keychain that the new version can not work with.